Bug 1731746 - Hammer full-help errors with uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Summary: Hammer full-help errors with uninitialized constant HammerCLIKatello::Lifecyc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.6.0
Assignee: Martin Bacovsky
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-21 17:14 UTC by Nikhil Kathole
Modified: 2019-10-22 13:32 UTC (History)
7 users (show)

Fixed In Version: rubygem-hammer_cli_foreman_docker-0.0.6.3-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 13:30:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27397 None None None 2019-07-23 23:26:53 UTC
Red Hat Product Errata RHBA-2019:3175 None None None 2019-10-22 13:32:42 UTC

Description Nikhil Kathole 2019-07-21 17:14:30 UTC
Description of problem:

Hammer full-help gives error

Error: uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Did you mean?  HammerCLIKatello::LifecycleEnvironmentNameMapping

# echo $?
70


Version-Release number of selected component (if applicable):
Satellite 6.6 snap 12

# rpm -qa | grep hammer
tfm-rubygem-hammer_cli_katello-0.18.0.2-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_openscap-0.1.7-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.13-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_virt_who_configure-0.0.3-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.4-5.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_admin-0.0.8-3.el7sat.noarch
tfm-rubygem-hammer_cli-0.17.1-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3.3-5.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_templates-0.1.2-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_discovery-1.0.0-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.17.0.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_ansible-0.3.0-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_remote_execution-0.1.0-3.el7sat.noarch


How reproducible: always


Steps to Reproduce:
1. hammer full-help


Actual results:

Error: uninitialized constant HammerCLIKatello::LifecycleEnvironmentNameResolvable
Did you mean?  HammerCLIKatello::LifecycleEnvironmentNameMapping


Expected results: No error on full-help command.


Additional info:
Regression.

Comment 5 Martin Bacovsky 2019-07-23 23:26:54 UTC
This issue has same root cause as https://bugzilla.redhat.com/show_bug.cgi?id=1730026. I'll keep the BZ open to track this particular use case.

Comment 6 Bryan Kearney 2019-07-24 10:03:30 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/27397 has been resolved.

Comment 8 Nikhil Kathole 2019-07-30 05:33:33 UTC
VERIFIED

Version tested:

# rpm -q satellite
satellite-6.6.0-5.beta.el7sat.noarch

# rpm -qa | grep rubygem-hammer_cli_
tfm-rubygem-hammer_cli_katello-0.18.0.2-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_openscap-0.1.7-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.13-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_virt_who_configure-0.0.3-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.6.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_admin-0.0.8-3.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3.3-5.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_templates-0.1.2-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_discovery-1.0.0-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.17.0.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_ansible-0.3.0-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_remote_execution-0.1.0-3.el7sat.noarch

No error seen on hammer full-help.

Comment 10 errata-xmlrpc 2019-10-22 13:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3175


Note You need to log in before you can comment on or make changes to this bug.