Bug 1731827 - [4.1.7] [Regression]"server returned HTTP status 500 Internal Server Error" for some kubelet endpoints
Summary: [4.1.7] [Regression]"server returned HTTP status 500 Internal Server Error" f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.z
Assignee: Ryan Phillips
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1734635 (view as bug list)
Depends On:
Blocks: 1750963
TreeView+ depends on / blocked
 
Reported: 2019-07-22 07:09 UTC by Junqi Zhao
Modified: 2019-09-10 20:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1750963 (view as bug list)
Environment:
Last Closed: 2019-08-15 14:24:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
kubelet logs (16.74 MB, application/gzip)
2019-07-23 01:34 UTC, Junqi Zhao
no flags Details
Prometheus 500 issue configuration 4.1.4 (12.78 KB, text/plain)
2019-08-09 17:19 UTC, Caden Marchese
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2417 None None None 2019-08-15 14:24:25 UTC
Github openshift origin pull 23524 None None None 2019-07-31 17:45:35 UTC

Comment 3 Junqi Zhao 2019-07-23 01:34:02 UTC
Created attachment 1592721 [details]
kubelet logs

Comment 6 Ryan Phillips 2019-07-30 16:01:23 UTC
Origin PR: https://github.com/openshift/origin/pull/23513

Comment 7 Seth Jennings 2019-07-31 14:19:33 UTC
*** Bug 1734635 has been marked as a duplicate of this bug. ***

Comment 8 Ryan Phillips 2019-07-31 17:46:58 UTC
Origin master PR merged.

Origin 4.1 Pick PR: https://github.com/openshift/origin/pull/23524

Comment 9 Seth Jennings 2019-08-05 14:21:47 UTC
Waiting on cherry-pick-approved for the backport PR

Comment 17 Caden Marchese 2019-08-09 17:19:07 UTC
Created attachment 1602254 [details]
Prometheus 500 issue configuration 4.1.4

Customer is experiencing the 500 error with Prometheus on 4.1.4. Attaching configuration information / reproducer from bug 1712645 in case it will help.

Comment 20 errata-xmlrpc 2019-08-15 14:24:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2417


Note You need to log in before you can comment on or make changes to this bug.