Bug 173220 - mt_alloc breaks scim symbol versioning
mt_alloc breaks scim symbol versioning
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
:
Depends On:
Blocks: FC5Blocker 166041 SCIM
  Show dependency treegraph
 
Reported: 2005-11-15 01:11 EST by Jens Petersen
Modified: 2013-08-09 01:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 04:02:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2005-11-15 01:11:33 EST
Description of problem:
Splitting this off from bug 166041, since it is really a separate
issue from the weak symbol versioning problem itself.

For FC4 and later, it seems the new mt_allocator causes problems:
for example if scim is built with --enable-ld-version-script
it now crashes on startup.

How reproducible:
every time

Steps to Reproduce:
see bug 166041#c21

Additional info:
Comment 1 Jens Petersen 2005-12-19 00:45:09 EST
This is now fixed with the gcc-4.1 in FC devel afaict.

Updating scim in next build to use its version scripts.

Note You need to log in before you can comment on or make changes to this bug.