Bug 173227 - OOo Writer crashes during cut and paste
OOo Writer crashes during cut and paste
Status: CLOSED DUPLICATE of bug 172940
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 07:09 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-15 07:24:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-11-15 07:09:52 EST
Description of problem:
I selected a selection of text, pressed ctrl X to delete and OOo died

Version-Release number of selected component (if applicable):
2.0.1-0.138-3.2

How reproducible:
Intermittent, but damned annoying!

Steps to Reproduce:
1. Select text to copy
2. Press crtl X
3.
  
Actual results:
Throwback given

0x5ef98a5: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e8a5
0x5efa0a8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f0a8
0x69a420:  + 0x420 (__kernel_sigreturn + 0x0)
0x6523820: /usr/lib/libicuuc.so.34 + 0x9f820
(icu_3_4::RuleBasedBreakIterator::RuleBasedBreakIterator(UDataMemory*,
UErrorCode&) + 0x56)
0x3bd499d: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x4299d
0x3bd5087: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x43087
0x3bd1f2b: /usr/lib/openoffice.org2.0/program/i18npool.uno.so + 0x3ff2b
0x2cb41bf: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x3b11bf
0x2ac10ba: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1be0ba
0x2ac1f54: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1bef54
0x2ac133a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1be33a
0x2ac4cee: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1c1cee
0x2ab786d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1b486d
(SwCrsrShell::LeftRight(unsigned char, unsigned short, unsigned short, unsigned
char) + 0x117)
0x2aa62a6: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1a32a6
0x2fd3653: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x6d0653
(SwWrtShell::Left(unsigned short, int, unsigned short, unsigned char, unsigned
char) + 0x6d)
0x2f59455: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x656455
0x2f4eb76: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x64bb76
0x7735006: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ab006
0x77343ea: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aa3ea
0x77348db: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aa8db
(SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short)
+ 0x137)
0x773db2e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b3b2e
0x772c3a9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a23a9
0x772c7db: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a27db
0x735c676: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0xe8676
0x735c738: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0xe8738
0x61c208c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8308c
0x635fd96: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x220d96
0x635fd7c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x220d7c
0x61c208c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8308c
0x631b4c9: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1dc4c9
0xe96e1e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ee1e
0xebd62e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4562e
(SalDisplay::DispatchInternalEvent() + 0xb0)
0x16e2fd: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x192fd
0xe12cbe: /usr/lib/libglib-2.0.so.0 + 0x26cbe
0xe10a50: /usr/lib/libglib-2.0.so.0 + 0x24a50 (g_main_context_dispatch + 0x1dc)
0xe13a66: /usr/lib/libglib-2.0.so.0 + 0x27a66
0xe13f48: /usr/lib/libglib-2.0.so.0 + 0x27f48 (g_main_context_iteration + 0x66)
0x16df23: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18f23
0xebe852: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46852
(X11SalInstance::Yield(unsigned char) + 0x28)
0x61c834c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8934c
(Application::Yield() + 0x48)
0x61c8382: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x89382
(Application::Execute() + 0x26)
0x7d2f7ba: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x257ba
(desktop::Desktop::Main() + 0x15b0)
0x61cd747: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e747
0x61cd7f7: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e7f7 (SVMain()
+ 0x29)
0x7d2705f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d05f (sal_main
+ 0x57)
0x7d270ab: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d0ab (main + 0x27)
0x8df50f: /lib/libc.so.6 + 0x1550f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4c5

Expected results:
The software should copy and paste!

Additional info:

Using gnome, rawhide. Locale - England
This may be related to #171873
Comment 1 Caolan McNamara 2005-11-15 07:24:52 EST

*** This bug has been marked as a duplicate of 172940 ***

Note You need to log in before you can comment on or make changes to this bug.