Bug 1732345 - iwl7260-firmware wifi firmware regression
Summary: iwl7260-firmware wifi firmware regression
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: iwl6050-firmware
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1732079 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 08:09 UTC by Jason Benaim
Modified: 2019-11-08 07:19 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-22 05:22:17 UTC


Attachments (Terms of Use)
dmesg with version -94 (good) (1.39 KB, text/plain)
2019-07-23 08:10 UTC, Jason Benaim
no flags Details
dmesg with -99 (bad) (28.20 KB, text/plain)
2019-07-23 08:11 UTC, Jason Benaim
no flags Details

Description Jason Benaim 2019-07-23 08:09:54 UTC
Description of problem:
Recently-released wifi firmware package iwl7260-firmware-1:25.30.13.0-99.fc30.noarch causes the wifi card to endlessly reset, rendering it dead to the user. Reverting to a previous version solves the issue, tested with iwl7260-firmware-1:25.30.13.0-94.fc30.noarch .


Version-Release number of selected component (if applicable):
iwl7260-firmware-1:25.30.13.0-99.fc30.noarch

How reproducible:


Steps to Reproduce:
1. Install the affected version of the firmware package listed above.
2. Restart the driver, either by rebooting the system or doing "rmmod iwlmvm iwlwifi ; modprobe iwlwifi"
3. Wifi card is now non-functional. Note errors in dmesg.

Actual results:
Wifi does not work

Expected results:
Wifi works.

Additional info:

Comment 1 Jason Benaim 2019-07-23 08:10:48 UTC
Created attachment 1592811 [details]
dmesg with version -94 (good)

Comment 2 Jason Benaim 2019-07-23 08:11:12 UTC
Created attachment 1592812 [details]
dmesg with -99 (bad)

Comment 3 Jason Benaim 2019-07-23 08:15:58 UTC
These bugs seem to be related:

> Latest iwlwifi driver crash at startup
https://bugzilla.redhat.com/show_bug.cgi?id=1732165

> dnf update 22nd July 2019 included WiFi Update; WiFi stopped working after update reboot
https://bugzilla.redhat.com/show_bug.cgi?id=1732079

Comment 4 Ryan David Sheasby 2019-07-23 08:25:57 UTC
Can confirm this bug. dnf undo transaction doesn't work either, as it tries to downgrade to 25.30.13.0-98 instead of 25.30.13.0-94. Manual downgrade to 25.30.13.0-94 fixes issue.

Comment 5 Khalsa Jings 2019-07-26 01:21:05 UTC
Thanks for the workaround advice. Took it.
Downgraded to iwl7260-firmware-25.30.13.0-94.fc30.noarch.rpm.
Added a line to /etc/dnf/dnf.conf: exclude=iwl7260-firmware*
WiFi confirmed working again.
Awaiting the iwlwifi bug fix.

Comment 6 Jop 2019-08-04 09:17:48 UTC
@khalsa, thank you for the steps to downgrade the driver firware. It resolved the issue for me (using a Dell precision 5530 laptop). I executed

> sudo dnf downgrade iwl7260-firmware


It is very annoying that upgrading can result in loss of wifi (happened multiple times now). New laptops do not have a wired connection option by default (or you need to have something like an usb-c to rj45 adapter at hand). Searching for a solution on the internet is more difficult and sometimes the downgrade is also only possible if there is an internet connection...

Comment 7 Erinn Looney-Triggs 2019-08-21 17:18:55 UTC
A new release is out, 25.30.13.0-101, can anyone confirm if the issue is fixed or not?

Comment 8 Erinn Looney-Triggs 2019-08-22 04:08:43 UTC
Confirmed that 101 fixes the issue. This can probably be closed.

Comment 9 Jason Benaim 2019-08-22 05:22:17 UTC
Hi- the problem is fixed now, not because of an upgrade to this package, but because of a new kernel.

Old kernel + -94 = works
Old kernel + -99 = broken
Old kernel + -101 = broken
New kernel + -101 = works

... where 'new kernel' is 5.2.9-200.fc30.x86_64.

I'll mark the ticket as closed. Thanks to everyone who helped take a look!

Comment 10 Khalsa Jings 2019-08-22 17:53:49 UTC
Confirmed. Working as described by Jason.

Comment 11 Jop 2019-08-22 18:07:01 UTC
Confirmed. Working with 5.2.9-200.fc30.x86_64 and iwl7260-firmware 25.30.13.0-101.fc30

Comment 12 Petr Bokoc 2019-11-08 07:19:57 UTC
*** Bug 1732079 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.