Bug 1732622 - TestImageStreamAdmitStatusUpdate test flake image AlreadyExists
Summary: TestImageStreamAdmitStatusUpdate test flake image AlreadyExists
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: David Eads
QA Contact: XiuJuan Wang
URL:
Whiteboard: buildcop
: 1731254 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-23 22:06 UTC by Seth Jennings
Modified: 2019-10-16 06:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:31:00 UTC

Internal Links: 1731254

Description Seth Jennings 2019-07-23 22:06:26 UTC
About 18 flakes in the last 7 days

https://search.svc.ci.openshift.org/?search=TestImageStreamAdmitStatusUpdate&maxAge=168h&context=7&type=all

# [Feature:Image][triggers][Serial] ImageStream admission TestImageStreamAdmitStatusUpdate [Suite:openshift/conformance/serial]
fail [github.com/openshift/origin/test/extended/images/imagestream_admission.go:407]: Unexpected error:
    <*errors.StatusError | 0xc0021dc000>: {
        ErrStatus: {
            TypeMeta: {Kind: "", APIVersion: ""},
            ListMeta: {SelfLink: "", ResourceVersion: "", Continue: ""},
            Status: "Failure",
            Message: "images.image.openshift.io \"sha256:c5207ce0f38da269ad2e58f143b5ea4b314c75ce1121384369f0db9015e10e82\" already exists",
            Reason: "AlreadyExists",

possibly related https://github.com/openshift/origin/pull/23379

Comment 2 David Eads 2019-07-24 13:50:50 UTC
may be helped by https://github.com/openshift/origin/pull/23466 if you want to have a look.

Comment 3 Steve Kuznetsov 2019-07-24 15:23:46 UTC
Seen about 25 times in the last day.

Comment 4 Ben Parees 2019-07-24 16:30:16 UTC
this looks like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1731254

i'm not going to close it because there's a PR in flight associated w/ this BZ, but when the dust settles, we should make sure the other BZ gets resolved.

Comment 5 Adam Kaplan 2019-07-29 21:42:52 UTC
Per bparees assigning this to David just so we track that the referenced PR has merged.

Note for QE - this BZ is to address a test flake and does not affect production code.

Comment 8 XiuJuan Wang 2019-08-01 02:08:54 UTC
The e2e test `[Feature:Image][triggers][Serial] ImageStream admission TestImageStreamAdmitStatusUpdate [Suite:openshift/conformance/serial]` has passed in aws-serial test suite of 4.2.0-0.nightly-2019-07-31-162901 payload.

Comment 9 Adam Kaplan 2019-08-23 13:47:59 UTC
*** Bug 1731254 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2019-10-16 06:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.