Bug 1732678 - Text overflows in Top Consumers table
Summary: Text overflows in Top Consumers table
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1739289 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 06:33 UTC by Yadan Pei
Modified: 2019-10-16 06:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
TextOverflowsInTopConsumers (386.16 KB, image/png)
2019-07-24 06:34 UTC, Yadan Pei
no flags Details
TopConsumersInFirefox (14.02 KB, image/png)
2019-08-05 07:13 UTC, Yadan Pei
no flags Details
TopConsumersInChrome (21.20 KB, image/png)
2019-08-05 07:13 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2198 0 'None' closed Bug 1732678: Fix text overflow in bar chart 2021-02-04 14:04:26 UTC
Github openshift console pull 2257 0 'None' closed Bug 1732678: Fix bar chart height in Firefox 2021-02-04 14:04:26 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:31:00 UTC

Description Yadan Pei 2019-07-24 06:33:40 UTC
Description of problem:
The long text overflows in Top Consumers table

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-24-000310

How reproducible:
Always

Steps to Reproduce:
1. cluster admin user login, view Top Consumers table on Home -> Dashboards 


Actual results:
1. We can see long text overflows the table

Expected results:
1. Long text should fit with the table 

Additional info:

Comment 1 Yadan Pei 2019-07-24 06:34:36 UTC
Created attachment 1593060 [details]
TextOverflowsInTopConsumers

Comment 2 Rastislav Wagner 2019-07-26 09:53:39 UTC
@Jon any idea how to deal with this issue ? I tried a few things but couldn't figure it out.

Comment 4 Yadan Pei 2019-08-05 07:12:45 UTC
Chrome displayed the table correctly while in Firefox, the tables are not showing in good format, see screenshot

Checked against registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-08-01-224308 with console commit 
io.openshift.build.commit.id=ee83581394a880fa7f33b971b4e3311337259168

Comment 5 Yadan Pei 2019-08-05 07:13:12 UTC
Created attachment 1600562 [details]
TopConsumersInFirefox

Comment 6 Yadan Pei 2019-08-05 07:13:37 UTC
Created attachment 1600563 [details]
TopConsumersInChrome

Comment 8 Samuel Padgett 2019-08-09 13:28:07 UTC
*** Bug 1739289 has been marked as a duplicate of this bug. ***

Comment 9 Yadan Pei 2019-08-12 03:32:32 UTC
Issue have been fixed on 

$ oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:d610d5b20346f54512d13ccad34bda66419f3f56b4c1f6cb6abca683cc862187 | grep commit
             io.openshift.build.commit.id=3d9532a92e0b2643418b8a51266cacdaec163a12
             io.openshift.build.commit.url=https://github.com/openshift/console/commit/3d9532a92e0b2643418b8a51266cacdaec163a12

Comment 10 errata-xmlrpc 2019-10-16 06:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.