Bug 173275 - Outdated/inconsistent browser list in webbrowser.py
Outdated/inconsistent browser list in webbrowser.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
: 179837 196346 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 15:46 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.4.3-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 10:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Try to prefer user's config, recognize current firefox (1018 bytes, patch)
2005-11-17 12:50 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-11-15 15:46:11 EST
The default web browser list in /usr/lib/python2.4/webbrowser.py seems   
outdated, and doesn't honor the system defaults (see the "Platform support for 
Unix" section). 
   
In particular, it doesn't try Firefox by it's name "firefox" (but uses some   
old variants), and tries "kfm" which should nowadays be "konqueror".  Also, it 
doesn't even try "gnome-open" or "htmlview", making it not support the user's 
configured default browser like most of the rest of the system does.
Comment 1 Mihai Ibanescu 2005-11-17 09:26:26 EST
Ville, can you please file a bug to the upstream python developers? I am usually
trying to do that myself for some bugzilla requests that are of high importance,
but it's fairly difficult to advocate for something I don't use - maybe you can
explain what your requirements are and possibly suggest a patch?
Comment 2 Ville Skyttä 2005-11-17 12:50:58 EST
Created attachment 121198 [details]
Try to prefer user's config, recognize current firefox

I checked upstream, and this appears to be pretty well addressd in svn trunk:
http://svn.python.org/view/python/trunk/Lib/webbrowser.py?rev=41419&view=auto

However, it's not quite there IMO, so I reported this:
https://sourceforge.net/tracker/index.php?func=detail&aid=1359150&group_id=5470&atid=105470


Finally, attached is a (untested) patch against Python 2.4.2 which I think
would cover the issue sufficiently well in the FC python package until the next
major Python version containing the above better implementation is out.  BTW,
it appears that the kfm/konqueror concern in the initial comment to this bug
was a false alarm.
Comment 3 Paul Howarth 2006-02-09 09:23:01 EST
I suspect that Bug 179837 is a duplicate of this. Anyone care to comment? If
agreed, I'll close that one as a dupe.
Comment 4 Paul Howarth 2006-03-01 03:53:08 EST
*** Bug 179837 has been marked as a duplicate of this bug. ***
Comment 5 Paul Howarth 2006-06-26 10:12:40 EDT
Some changes to this bug were lost in the bugzilla crash. Here they are again:

------- Additional Comments From misa@redhat.com  2006-06-12 15:45 EST -------
Ville,

The patch you reference above does not apply cleanly on 2.4.3 - substantial work
has been done in HEAD to make it too risky to pull that version of webbrowser.py
into 2.4.3. Do you agree?

------ Additional Comments From ville.skytta@iki.fi  2006-06-12 18:00 EST -------
I agree that pulling from HEAD would be a pretty courageous move, but note that
the patch in comment 2 (attachment 121198 [details]) still does apply cleanly to 2.4.3,
and my "Finally, ..." comment there still applies too, FWIW...

------- Additional Comments From misa@redhat.com  2006-06-12 18:06 EST -------
Fair enough - I was only looking at
http://svn.python.org/view/python/trunk/Lib/webbrowser.py?p2=%2Fpython%2Ftrunk%2FLib%2Fwebbrowser.py&p1=python%2Ftrunk%2FLib%2Fwebbrowser.py&r1=41511&r2=41510&rev=41511&view=diff&makepatch=1&diff_format=u

------- Additional Comments From misa@redhat.com  2006-06-12 18:15 EST -------
Should be fixed in 2.4.3-7 and newer
Comment 6 Fedora Update System 2006-06-26 15:31:37 EDT
python-2.4.3-8.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Paul Howarth 2006-08-10 13:12:41 EDT
*** Bug 196346 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.