Bug 1732906 - rubygem-katello should trigger db:seed
Summary: rubygem-katello should trigger db:seed
Keywords:
Status: CLOSED DUPLICATE of bug 1732921
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 16:40 UTC by Jonathon Turel
Modified: 2019-07-24 17:30 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-24 17:30:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27424 None None None 2019-07-24 16:40:49 UTC

Description Jonathon Turel 2019-07-24 16:40:49 UTC
Since we've moved to using the UpgradeTask model[1] of Foreman via seeds[2] we need to be absolutely certain that db:seed runs during installation and upgrades so that all of the upgrade tasks are executed. We can't rely on the potential side-effect of other actions during installation or upgrade to do the seed for us.



[1] https://github.com/theforeman/foreman/pull/5780/files
[2] https://github.com/Katello/katello/blob/master/db/seeds.d/111-upgrade_tasks.rb

Comment 1 Jonathon Turel 2019-07-24 16:40:51 UTC
Created from redmine issue https://projects.theforeman.org/issues/27424

Comment 3 Jonathon Turel 2019-07-24 17:30:43 UTC

*** This bug has been marked as a duplicate of bug 1732921 ***


Note You need to log in before you can comment on or make changes to this bug.