Bug 1732921 - upgrades should trigger db:seed
Summary: upgrades should trigger db:seed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.5.2
Assignee: Jonathon Turel
QA Contact: Stephen Wadeley
URL:
Whiteboard:
: 1732906 1732907 1732916 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 17:28 UTC by Jonathon Turel
Modified: 2019-10-30 17:02 UTC (History)
3 users (show)

Fixed In Version: katello-installer-base-3.10.0.8-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1734092 (view as bug list)
Environment:
Last Closed: 2019-08-06 14:37:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27424 None None None 2019-07-24 17:32:19 UTC
Red Hat Product Errata RHBA-2019:2363 None None None 2019-08-06 14:37:51 UTC

Description Jonathon Turel 2019-07-24 17:28:41 UTC
Description of problem:

Upgrading to 6.5.2 does not trigger db:seed and so any new UpgradeTasks are not being run such as the one required by https://bugzilla.redhat.com/show_bug.cgi?id=1726824


Version-Release number of selected component (if applicable): 6.5.2


How reproducible: Always


Steps to Reproduce:
1. Upgrade from 6.5.1 to 6.5.2
2. Check the Rails console for the UpgradeTasks
> foreman-rake console
> UpgradeTask.all


Actual results: Out from (2) does not show 'katello:upgrades:3.10:update_gpg_key_urls'

Expected results: 'katello:upgrades:3.10:update_gpg_key_urls' should be represented by (2) so that it will be run during the upgrade


Additional info:

Comment 3 Jonathon Turel 2019-07-24 17:30:43 UTC
*** Bug 1732906 has been marked as a duplicate of this bug. ***

Comment 4 Jonathon Turel 2019-07-24 17:31:08 UTC
*** Bug 1732907 has been marked as a duplicate of this bug. ***

Comment 5 Jonathon Turel 2019-07-24 17:31:16 UTC
*** Bug 1732916 has been marked as a duplicate of this bug. ***

Comment 6 Jonathon Turel 2019-07-24 17:32:18 UTC
Connecting redmine issue https://projects.theforeman.org/issues/27424 from this bug

Comment 7 Mike McCune 2019-07-29 15:19:43 UTC
upstream is merged, moving to POST

Comment 10 Mike McCune 2019-07-31 13:59:24 UTC
Upgraded to latest 6.5.2 SNAP 2 and db:seed ran in the installer correctly:


[ INFO 2019-07-31T00:18:20 main]  Foreman::Rake[db:seed]: Starting to evaluate the resource
[ INFO 2019-07-31T00:18:20 main]  Foreman::Rake[db:seed]: Evaluated in 0.00 seconds
...
[DEBUG 2019-07-31T00:19:30 main] All seed files executed
[DEBUG 2019-07-31T00:19:30 main] foreman-rake db:seed finished successfully!

Comment 13 errata-xmlrpc 2019-08-06 14:37:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2363


Note You need to log in before you can comment on or make changes to this bug.