Bug 173293 - File name is lost in File-Save dialog when a new folder is created
File name is lost in File-Save dialog when a new folder is created
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 19:04 EST by Matt Morgan
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:49:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Morgan 2005-11-15 19:04:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
In the File-Save dialog, when I create a new folder, the file name disappears from the "Name" box in the dialog. Seems to be gnome-wide; I see it whether saving images in Firefox, or saving documents in OOo, for example.

It happens when I hit enter to complete the naming of the new folder, or if I click into the new name's box. If I click on another flie in the list of files, it works right--that is, the new folder is created, focus is moved into it, and the filename is preserved. But if there are no other files in that folder, then there's no workaround, and anyway it's nice to hit enter to save a folder name.

Version-Release number of selected component (if applicable):
gnome-desktop-2.10.0-5

How reproducible:
Always

Steps to Reproduce:
1. Right-click on an image on a web page and pick "Save Image As."
2. Click "browse for other folders."
3. Click on the "new folder" button.
4a. Type in a name for the new folder and hit enter, or
4b. Type in a name for the new folder and click almost anywhere except on another filename in the list.
  

Actual Results:  The filename in the "Name" box disappears.

Expected Results:  The filename should have remained in the "Name" box.

Additional info:
Comment 1 Matt Morgan 2005-11-15 19:07:36 EST
Oops. Step three should be

3. Click on the "Create folder" button.

Thanks.
Comment 2 Jeff Spirko 2005-12-06 16:36:06 EST
This seems to be a duplicate of bug 169899.  Firefox and gedit do it, too.
Comment 3 Peter Bieringer 2006-02-12 16:40:25 EST
Is there any work ongoing? Hopefully at least FC5 will get a fix for that issue.
Comment 4 Christian Iseli 2007-01-22 06:04:19 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 5 Peter Bieringer 2007-01-22 06:34:59 EST
At least solved in FC6
Comment 6 Matt Morgan 2007-01-22 12:28:30 EST
it is also solved in FC5, as far as I can tell. This bug can be closed, I think.
Comment 7 Ray Strode [halfline] 2007-08-14 11:49:36 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.