Bug 1733399 - Incorrect link for Expression in Alerting Rule Overview page
Summary: Incorrect link for Expression in Alerting Rule Overview page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 02:10 UTC by Junqi Zhao
Modified: 2019-10-16 06:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2217 None None None 2019-07-30 13:06:15 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:33:59 UTC

Description Junqi Zhao 2019-07-26 02:10:02 UTC
Description of problem:
login cluster console as admin and find one alert, such as Watchdog, then go to the Alerting Rule Overview page,
Expression for Watchdog is vector(1), then click the link, it navigates to ${console_url}/monitoring/query-browser?query=vector(1)
but the grpah is empty, the metrics is not in the query-input textarea

the link may should be:
${console_url}/monitoring/query-browser?query0=vector(1)

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-24-000310

How reproducible:
Always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
the grpah is empty, the metrics is not in the query-input textarea

Expected results:
should see the result both in graph and the table under the query-input textarea

Additional info:

Comment 3 Junqi Zhao 2019-08-01 03:32:49 UTC
Issue is fixed, link is right for Expression in Alerting Rule Overview page, but there is a small bug, see Bug 1735520
payload: 4.2.0-0.nightly-2019-07-31-162901

Comment 4 errata-xmlrpc 2019-10-16 06:33:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.