Bug 1733676 - [RFE] automatic power off by default
Summary: [RFE] automatic power off by default
Keywords:
Status: CLOSED DUPLICATE of bug 651479
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-27 08:03 UTC by Dan Kenigsberg
Modified: 2019-11-07 14:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 14:29:02 UTC


Attachments (Terms of Use)

Description Dan Kenigsberg 2019-07-27 08:03:10 UTC
Description of problem:
Currently, it is quite common to find unused hosts that are up for months, wasting money and energy.

Feature request:
Every Beaker host should have a default shutdown deadline of (say) 30 days since its most recent Beaker usage. The owner of the machine should be able to set a longer deadline (even of 5 years). Lab manager may search for hosts with distant-future deadlines, and ask their owners for their reasoning.

Comment 1 Tomas Klohna 🔧 2019-10-01 13:01:01 UTC
Dan, what do you mean "up"? Default power settings in most hosts are set to "Power off". Any other settings need to be discussed with Labs. Are we talking about machines that are loaned/reserved?

Comment 2 Dan Kenigsberg 2019-10-23 02:38:59 UTC
Yes, by "up" I mean "with power on". I'm not sure what you're saying about "default power settings" and where are they being set.

When I loan/reserve a machine, or when I simply own a machine, I'd like to set its shutdown interval (say 30 days since borrower/reserver/owner modifies it in Beaker. When that time passes, Beaker would shut the host down.

I do not want to discuss it with lab technicians; I'd like to give each host owner the flexibility to set their own deadline. Lab technicians can still search and find if someone is abusing it.

Comment 4 Dan Kenigsberg 2019-11-07 11:07:12 UTC
Thanks for letting me know of "Release Action: PowerOff"

Yes, I would like to have the *ability* to set a timer to shut down machines that are still on active loan.
Alternatively, I'd like to be able to set a timer on the loan itself. If I am the owner of the machine, I'd like to explicitly set the length of the loan.

I understand that some users would like infinite loans and uptime. Fine. But many other want to save power costs, but simply forget to return their loan.

Comment 5 Tomas Klohna 🔧 2019-11-07 14:29:02 UTC
In that case Dan I think we can work on that!

There is already a request for time-based loans - https://bugzilla.redhat.com/show_bug.cgi?id=651479
I will be closing this issue as a duplicate of that one.

If you're interested in any other loan issue request, there are also these two RFEs:
* https://bugzilla.redhat.com/show_bug.cgi?id=651477
* https://bugzilla.redhat.com/show_bug.cgi?id=1324974

We need to create a design proposal around this first, but it will be handled.

*** This bug has been marked as a duplicate of bug 651479 ***


Note You need to log in before you can comment on or make changes to this bug.