Bug 173375 - Problems with schema matching rules
Problems with schema matching rules
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
7.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Whitehurst
Viktor Ashirov
1.0.2
:
: 173376 192267 (view as bug list)
Depends On:
Blocks: 183369
  Show dependency treegraph
 
Reported: 2005-11-16 13:58 EST by Danney
Modified: 2015-12-07 11:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:52:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.91 KB, patch)
2006-01-06 15:58 EST, Pete Rowley
no flags Details | Diff
modified patch (strncat length changed) (2.92 KB, patch)
2006-01-06 16:52 EST, Pete Rowley
no flags Details | Diff

  None (edit)
Description Danney 2005-11-16 13:58:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
Some tools have problems parsing schema matching rules:

A dump of the LDIF (cn=schema) shows "matchingRules entries with parts of names mising (i.e. "-ar" instead of "caseIgnoreSubstringMatch-ar")


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get LDIF export of cn=schema

  

Actual Results:  matchingRules entries appeared to be mangled for most entries.

Expected Results:  Expected well formed entries such as "caseIgnoreSubstringMatch-ar", not "-ar".

Additional info:

Other tools such as JXplorer, have issues with parsing matching rules and thus produce mangled entiries as well.


Novell's Java API throws an exception with LDAPConnection.fetchSchema() method 

java.lang.NullPointerException
        at com.novell.ldap.LDAPMatchingRuleSchema.<init>(Unknown Source)
        at com.novell.ldap.LDAPSchema.<init>(Unknown Source)
        at com.novell.ldap.LDAPConnection.fetchSchema(Unknown Source)

The same capabilities work in similar directory servers such as Sun's 5.2 version.


Without the ability to correctly read and process schema attribute values, large numbers of tools which perform operations based on data types defined for attributes will fail.
Comment 1 Rahul Sundaram 2005-11-18 07:08:48 EST
*** Bug 173376 has been marked as a duplicate of this bug. ***
Comment 2 Pete Rowley 2006-01-06 15:59:00 EST
Created attachment 122892 [details]
proposed patch
Comment 3 Pete Rowley 2006-01-06 16:52:13 EST
Created attachment 122895 [details]
modified patch (strncat length changed)
Comment 4 Pete Rowley 2006-01-06 16:53:15 EST
Checking in collate.c;
/cvs/dirsec/ldapserver/ldap/servers/plugins/collation/collate.c,v  <--  collate.c
new revision: 1.7; previous revision: 1.6
done
Comment 5 Noriko Hosoi 2006-05-18 14:41:04 EDT
*** Bug 192267 has been marked as a duplicate of this bug. ***
Comment 6 Yi Zhang 2007-11-26 20:34:11 EST
Verified: PASS


LDAP Search command issued:
 /usr/lib/mozldap/ldapsearch -h localhost -p 389 -D "cn=directory manager" -w
Secret123 -s sub -b "cn=schema"  "" "*"

And the output contains: 
matchingRules: ( 2.16.840.1.113730.3.3.2.0.1.6 NAME 'caseIgnoreSubstringMatch-
 default' SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 )

Note You need to log in before you can comment on or make changes to this bug.