Bug 173376 - Problems with schema matching rules
Problems with schema matching rules
Status: CLOSED DUPLICATE of bug 173375
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
7.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 14:01 EST by Danney
Modified: 2008-08-11 19:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-18 07:08:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danney 2005-11-16 14:01:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
Some tools have problems parsing schema matching rules:

A dump of the LDIF (cn=schema) shows "matchingRules entries with parts of names mising (i.e. "-ar" instead of "caseIgnoreSubstringMatch-ar")


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get LDIF export of cn=schema

  

Actual Results:  matchingRules entries appeared to be mangled for most entries.

Expected Results:  Expected well formed entries such as "caseIgnoreSubstringMatch-ar", not "-ar".

Additional info:

Other tools such as JXplorer, have issues with parsing matching rules and thus produce mangled entiries as well.


Novell's Java API throws an exception with LDAPConnection.fetchSchema() method 

java.lang.NullPointerException
        at com.novell.ldap.LDAPMatchingRuleSchema.<init>(Unknown Source)
        at com.novell.ldap.LDAPSchema.<init>(Unknown Source)
        at com.novell.ldap.LDAPConnection.fetchSchema(Unknown Source)

The same capabilities work in similar directory servers such as Sun's 5.2 version.


Without the ability to correctly read and process schema attribute values, large numbers of tools which perform operations based on data types defined for attributes will fail.
Comment 1 Rahul Sundaram 2005-11-18 07:08:31 EST

*** This bug has been marked as a duplicate of 173375 ***
Comment 2 Chandrasekar Kannan 2008-08-11 19:42:36 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.