Bug 173389 - libXmu-devel missing dependencies
Summary: libXmu-devel missing dependencies
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libXmu (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: xorg-modular
TreeView+ depends on / blocked
 
Reported: 2005-11-16 20:40 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 01:20:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2005-11-16 20:40:44 UTC
libXmu-devel 0.99.1-2 seems to be missing a lot of other -devel dependencies, 
see the pkgconfig file and #includes in installed headers.

Comment 1 Mike A. Harris 2005-11-17 02:22:52 UTC
Thanks for the report.

The pkg config files in modular X are all broken right now, and specify
a bunch of things that they should not.  This is currently being fixed
in upstream CVS by Kevin Martin.

I'll leave this open to track the issue for now, until we decide wether
we're going to wait for X11R7 RC3, or apply patches from CVS.



Comment 2 Mike A. Harris 2005-12-15 01:20:41 UTC
Thanks, with RC3's fixed pkgconfig files, I've barebonesed the deps, and did
a rebuild with a bare system, only installing listed deps.  Needed to add
pkgconfig and libXau-devel, and now she builds cleanly.

Fixed in libXmu-0.99.2-1


Note You need to log in before you can comment on or make changes to this bug.