Bug 173395 - Booting laptop freezes when loading ehci-hcd
Booting laptop freezes when loading ehci-hcd
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-11-16 17:47 EST by Roy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-04 08:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Roy 2005-11-16 17:47:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8) Gecko/20051025 Firefox/1.5

Description of problem:
The 2.6.13-* and 2.6.14-* kernels freezes (completely locks up without an error message) when booting on my Asus A6K notebook. This device contains a sis chipset, nVidia graphics and an AMD Turion processor (x86_64).
By editing the initscript I found out the freeze occurs every time just after loading the ehci-hcd module (and before trying to load any other module). This does not occur when booting a 2.6.12 kernel or previous.

Version-Release number of selected component (if applicable):
Kernel 2.6.13-*/2.6.14-*

How reproducible:

Steps to Reproduce:
1. Boot laptop with 2.6.13 or 2.6.14 kernel

Actual Results:  Lockup during rc.sysinit

Expected Results:  A happy machine

Additional info:

I have no idea if this module can be disabled in any way to make the kernel at least boot. However, I believe there is a serious bug in the ehci-hcd module that needs to be fixed.
Comment 1 Pete Zaitcev 2005-11-16 18:52:35 EST
Would you give me the precise version of that "a 2.6.12 kernel" which worked?
Then I could look for changes.
Comment 2 Roy 2005-11-17 10:58:34 EST
2.6.12-1.1456 is the last one that worked... with this kernel ACPI didn't work
Comment 3 Roy 2005-12-06 16:07:40 EST
For the record, kernel-devel-2.6.14-1.1644_FC4 still has this problem.
Comment 4 Roy 2005-12-12 16:58:30 EST
That had to be kernel-2.6.14-1.1644_FC4 ofcourse.
Furthermore I'm absolutely positive that ehci-hcd is the problem. I've altered
rc.sysinit to skip loading ehci-hcd (mean little if-statement :p), and with that
if-statement the laptop boots perfectly fine. I don't know what the loss in
functionality is with this alteration thou, but it's a bug that needs to be
fixed anyhow.
Thanks for your help so far by the way.
Comment 5 Dave Jones 2006-02-03 00:12:04 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 6 John Thacker 2006-05-04 08:50:56 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.