Bug 1734457 - [ci] [aws] test failure: Prometheus alerts for openshift-origin-installer-e2e-aws-4.2
Summary: [ci] [aws] test failure: Prometheus alerts for openshift-origin-installer-e2...
Keywords:
Status: CLOSED DUPLICATE of bug 1743353
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.2.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 15:02 UTC by Lokesh Mandvekar
Modified: 2019-08-30 14:51 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-29 20:50:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lokesh Mandvekar 2019-07-30 15:02:32 UTC
Description of problem:

See: https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-4.2/2630

Test failure seen: 

[Feature:Prometheus][Conformance] Prometheus when installed on the cluster should report less than two alerts in firing or pending state [Suite:openshift/conformance/parallel/minimal] 	11m41s
fail [github.com/openshift/origin/test/extended/prometheus/prometheus_builds.go:167]: Expected
    <map[string]error | len:1>: {
        "sum(ALERTS{alertstate=\"firing\"})": {
            s: "query sum(ALERTS{alertstate=\"firing\"}) for tests []prometheus.metricTest{prometheus.metricTest{labels:map[string]string(nil), greaterThanEqual:false, value:2, success:false}} had results {\"status\":\"success\",\"data\":{\"resultType\":\"vector\",\"result\":[{\"metric\":{},\"value\":[1564493798.112,\"2\"]}]}}",
        },
    }
to be empty

Not sure if related to Bug 1734454

Comment 2 Daniel Spangenberg 2019-08-01 19:33:56 UTC
Looks more like a dup of Bug 1707495

Comment 5 Dan Mace 2019-08-14 20:35:42 UTC
I don't see any indication of flakiness on master[1].

Can you provide a CI search query which would indicate there's a significant PR flake?

I don't currently see this as a release blocker, but am open to changing my mind if there's some justification. If you have one, please let us know and we'll re-assess.

[1] https://testgrid.k8s.io/redhat-openshift-release-blocking#redhat-release-openshift-origin-installer-e2e-aws-serial-4.2

Comment 7 Dan Mace 2019-08-29 20:50:19 UTC
Trying to consolidate the auth related flakes. Closing as a dupe.

*** This bug has been marked as a duplicate of bug 1743353 ***


Note You need to log in before you can comment on or make changes to this bug.