Bug 1734534 - Upgrading a RHGS node fails when user edited glusterd.vol file exists
Summary: Upgrading a RHGS node fails when user edited glusterd.vol file exists
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.5.0
Assignee: Sanju
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On: 1737676
Blocks: 1696809 1729027
TreeView+ depends on / blocked
 
Reported: 2019-07-30 19:36 UTC by Raghavendra Talur
Modified: 2019-11-20 07:00 UTC (History)
7 users (show)

Fixed In Version: glusterfs-6.0-12
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1737676 (view as bug list)
Environment:
Last Closed: 2019-10-30 12:22:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3249 None None None 2019-10-30 12:23:03 UTC

Description Raghavendra Talur 2019-07-30 19:36:43 UTC
Description of problem:
When a user had edited the glusterd.vol file in /etc/glusterfs and updates the glusterfs packages, bricks cannot contact glusterd.

Version-Release number of selected component (if applicable):
RHGS 3.5.0


How reproducible:
Always

Steps to Reproduce:
1. install glusterfs
2. create and start a volume
3. edit glusterd.vol and add a custom option
4. yum update gluster packages
5. restart volumes

Comment 13 errata-xmlrpc 2019-10-30 12:22:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.