Bug 1734717 - Update LV cache related variables in generated vars file
Summary: Update LV cache related variables in generated vars file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.6.z Async Update
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1738019
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 09:55 UTC by SATHEESARAN
Modified: 2019-10-03 12:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1738019 (view as bug list)
Environment:
Last Closed: 2019-10-03 12:24:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2963 None None None 2019-10-03 12:24:08 UTC

Description SATHEESARAN 2019-07-31 09:55:25 UTC
Description of problem:
-------------------------
Few of the params in lvcache section are not required and will be auto-computed

Following variables are not required:
          cachethinpoolname: gluster_thinpool_gluster_vg_sdd
          cachemetalvsize: 2G


Version-Release number of selected component (if applicable):
---------------------------------------------------------------
RHHI-V 1.6
cockpit-ovirt-dashboard-0.13.5


How reproducible:
-----------------
NA


Steps to Reproduce:
--------------------
1. Enable lv cache 

Actual results:
---------------
1. cache lv meta size is computed
2. lv cache meta name is computed

Expected results:
------------------
When the above said options are not mentioned, lv cache meta is automatically computed by LV which is more safer


Additional info:

Comment 1 Gobinda Das 2019-08-06 12:53:15 UTC
Hi sas,
 We can't remove "cachethinpoolname" as we have feature to attach specific thinpool to lv cache(https://bugzilla.redhat.com/show_bug.cgi?id=1712714)
We can remove cachemetalvsize and let's it to be auto calculated.

Comment 2 SATHEESARAN 2019-09-03 05:15:09 UTC
(In reply to Gobinda Das from comment #1)
> Hi sas,
>  We can't remove "cachethinpoolname" as we have feature to attach specific
> thinpool to lv cache(https://bugzilla.redhat.com/show_bug.cgi?id=1712714)
> We can remove cachemetalvsize and let's it to be auto calculated.

That's right. As I clarified in google chat, its the lvcachemetaname that I wanted to remove,
but its a typo in the description

Comment 3 SATHEESARAN 2019-09-03 05:16:27 UTC
Tested with cockpit-ovirt-dashboard-0.13.6

All the optional params for lvcache are removed, leaving LVM
to compute it by default.

LV cache related params in the generated vars file looks like:

<snip>
      gluster_infra_cache_vars:
        - vgname: gluster_vg_sdb
          cachedisk: '/dev/sdb,/dev/sdc'
          cachelvname: cachelv_gluster_thinpool_gluster_vg_sdb
          cachethinpoolname: gluster_thinpool_gluster_vg_sdb
          cachelvsize: 225G
          cachemode: writeback
</snip>

Comment 5 errata-xmlrpc 2019-10-03 12:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2963


Note You need to log in before you can comment on or make changes to this bug.