Bug 1734724 - [RFE] Update aaa-ldap to use OpenJDK 11 - both build and runtime
Summary: [RFE] Update aaa-ldap to use OpenJDK 11 - both build and runtime
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-extension-aaa-ldap
Classification: oVirt
Component: General
Version: 1.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.4.0
: 1.4.0
Assignee: Martin Perina
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1641336 (view as bug list)
Depends On:
Blocks: 1734716 1752890 1828098
TreeView+ depends on / blocked
 
Reported: 2019-07-31 10:03 UTC by Martin Perina
Modified: 2020-05-20 20:04 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-extension-aaa-ldap-1.4.0
Doc Type: Enhancement
Doc Text:
We should update below RHV Administration Guide for 4.4 chapters: 16.3.3. Configuring an External LDAP Provider (Manual Method) https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.3/html/administration_guide/sect-configuring_an_external_ldap_provider#Configuring_an_External_LDAP_Provider_ManualMethod 16.4. Configuring LDAP and Kerberos for Single Sign-on https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.3/html/administration_guide/configuring_ldap_and_kerberos_for_single_sign-on and replace below strings: 1. From "org.ovirt.engine-extensions.aaa" to "org.ovirt.engine.extension.aaa" 2. From "org.ovirt.engineextensions.aaa" to "org.ovirt.engine.extension.aaa" Those replacement are only breaking changes contained in version 1.4.0 compared to 1.3.0, but for upgrades from 4.3 those changes will be performed automatically as a part of engine-setup. So we just need to fix documentation mentioning manual setup of new LDAP integration.
Clone Of:
: 1828098 (view as bug list)
Environment:
Last Closed: 2020-05-20 20:04:25 UTC
oVirt Team: Infra
mperina: ovirt-4.4?
pelauter: planning_ack+
mperina: devel_ack+
lleistne: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 107214 0 None MERGED Align java package with other engine extensions 2020-09-28 08:44:50 UTC
oVirt gerrit 107215 0 None MERGED Move non-java files under packaging directory 2020-09-28 08:44:44 UTC
oVirt gerrit 107216 0 None MERGED Use maven instead of ant 2020-09-28 08:44:44 UTC
oVirt gerrit 107271 0 None MERGED Fix references to java classes 2020-09-28 08:44:44 UTC
oVirt gerrit 107298 0 None MERGED Fix Python 3 incompatibilitites in setup tool 2020-09-28 08:44:49 UTC

Internal Links: 1828098

Description Martin Perina 2019-07-31 10:03:02 UTC
aaa-ldap needs to align with oVirt engine and use OpenJDK 11 instead of 8

Comment 2 Martin Perina 2020-03-02 15:07:15 UTC
*** Bug 1641336 has been marked as a duplicate of this bug. ***

Comment 7 Petr Matyáš 2020-03-23 12:28:58 UTC
Verified on ovirt-engine-extension-aaa-ldap-1.4.0-1.el8ev.noarch

Upgrade will be fixed as part of another bug.

Comment 8 Sandro Bonazzola 2020-05-20 20:04:25 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.