Bug 1734813 - [OSP 15] rbd connection timeouts will lead to n-cpu hanging
Summary: [OSP 15] rbd connection timeouts will lead to n-cpu hanging
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z1
: 15.0 (Stein)
Assignee: Lee Yarwood
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks: 1734814 1734815 1734818
TreeView+ depends on / blocked
 
Reported: 2019-07-31 14:16 UTC by Lee Yarwood
Modified: 2019-09-19 14:28 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1734814 (view as bug list)
Environment:
Last Closed: 2019-09-19 14:28:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1834048 None None None 2019-07-31 14:16:08 UTC
OpenStack gerrit 669167 'None' 'ABANDONED' 'libvirt: Add a rbd_connect_timeout configurable' 2019-12-01 01:48:23 UTC

Description Lee Yarwood 2019-07-31 14:16:09 UTC
Description of problem:
This was originally reported upstream but has recently been seen downstream by a number of customers with connectivity issues in their env.

Nova waits indefinitely on ceph client hangs due to network problems
https://bugs.launchpad.net/nova/+bug/1834048


Version-Release number of selected component (if applicable):
OSP 15.beta

How reproducible:
Always.

Steps to Reproduce:
1. Deploy environment.
2. Later block access to the rbd cluster.

Actual results:
n-cpu will wait indefinitely while attempting to connect.

Expected results:
n-cpu should fail and mark the host as DOWN until connectivity is re-established. 

Additional info:


Note You need to log in before you can comment on or make changes to this bug.