Bug 1734818 - [OSP 10] rbd connection timeouts will lead to n-cpu hanging
Summary: [OSP 10] rbd connection timeouts will lead to n-cpu hanging
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Artom Lifshitz
QA Contact: nova-maint
URL:
Whiteboard:
Depends On: 1734813 1734814 1734815
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 14:24 UTC by Lee Yarwood
Modified: 2019-09-19 14:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1734815
Environment:
Last Closed: 2019-09-19 14:29:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lee Yarwood 2019-07-31 14:24:24 UTC
+++ This bug was initially created as a clone of Bug #1734815 +++

+++ This bug was initially created as a clone of Bug #1734814 +++

+++ This bug was initially created as a clone of Bug #1734813 +++

Description of problem:
This was originally reported upstream but has recently been seen downstream by a number of customers with connectivity issues in their env.

Nova waits indefinitely on ceph client hangs due to network problems
https://bugs.launchpad.net/nova/+bug/1834048


Version-Release number of selected component (if applicable):
OSP 15.beta

How reproducible:
Always.

Steps to Reproduce:
1. Deploy environment.
2. Later block access to the rbd cluster.

Actual results:
n-cpu will wait indefinitely while attempting to connect.

Expected results:
n-cpu should fail and mark the host as DOWN until connectivity is re-established. 

Additional info:


Note You need to log in before you can comment on or make changes to this bug.