Bug 173482 - problem booting on an hp nx8220
problem booting on an hp nx8220
Status: CLOSED DUPLICATE of bug 169738
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-11-17 10:04 EST by E. Lefty Kreouzis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-21 11:41:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description E. Lefty Kreouzis 2005-11-17 10:04:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When booting the latest kernel 2.6.24-1.1637 the notebook freezes just after the lines:

PCI using ACPI for IRQ routing
PCI .... use pci=routeirq
PCI Cannot allocate resource region 7 of bridge 0000:00:1c:1
PCI Cannot allocate resource region 8 of bridge 0000:00:1c:1

kernel-2.6.11-1.1369_FC4 boots perfectly

I tried both with and without the pci= kernel option

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
2.From Grub choose to boot kernel-2.6.14-1.1637_FC4

Actual Results:  System froza after displaying the above lines

Expected Results:  The system should have booted normally

Additional info:
Comment 1 Kostas Georgiou 2005-11-17 20:18:22 EST
I've seen the same error in an nc8230 as well. The kernel from the fc4 release
boots fine but the latest three ones that i tried fail with the same error.
Comment 2 E. Lefty Kreouzis 2005-11-18 04:16:48 EST
I tried booting with both stock 2.6.14 and and the same error occurs

when I tried booting with acpi=off it stopped with a message saying "unable to
initialize device 1c:1"

output from lspci -v -v -v

00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Ex
press Port 2 (rev 03) (prog-if 00 [Normal decode])
        Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Step
ping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size 10
        Bus: primary=00, secondary=20, subordinate=20, sec-latency=0
        I/O behind bridge: 00000000-00000fff
        Memory behind bridge: 00000000-000fffff
        Prefetchable memory behind bridge: 0000000000000000-0000000000000000
        Secondary status: 66Mhz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA+ VGA- MAbort- >Reset- FastB2B-
        Capabilities: [40] Express Root Port (Slot+) IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s unlimited, L1 unlimited
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 2
                Link: Latency L0s <1us, L1 <4us
                Link: ASPM Disabled RCB 64 bytes CommClk- ExtSynch-
                Link: Speed 2.5Gb/s, Width x1
                Slot: AtnBtn- PwrCtrl- MRL- AtnInd- PwrInd- HotPlug+ Surpise+
                Slot: Number 3, PowerLimit 16.000000
                Slot: Enabled AtnBtn+ PwrFlt- MRL- PresDet+ CmdCplt- HPIrq-
                Slot: AttnInd Unknown, PwrInd Unknown, Power-
                Root: Correctable- Non-Fatal- Fatal- PME-
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable -
                Address: 00000000  Data: 0000
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [100] Virtual Channel
        Capabilities: [180] Unknown (5)
Comment 3 Kostas Georgiou 2005-11-18 09:12:55 EST
From the following posts in lkml it seems that the problem started with the 2.6.13
Comment 4 E. Lefty Kreouzis 2005-11-18 09:37:18 EST
Booting with pci=noacpi works for both stock 2.6.24 and for kernel-2.6.14-1.1637_FC4
Comment 5 E. Lefty Kreouzis 2005-11-18 10:15:18 EST
There is the following bug in Suse that seems to be related

Comment 6 Dave Jones 2005-11-21 11:41:16 EST

*** This bug has been marked as a duplicate of 169738 ***

Note You need to log in before you can comment on or make changes to this bug.