Bug 1734895 - R-data.table: FTBFS in Fedora rawhide/f31
Summary: R-data.table: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: R-data.table
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1735426 (view as bug list)
Depends On: 1763127
Blocks: F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 16:09 UTC by Fedora Release Engineering
Modified: 2020-02-08 02:01 UTC (History)
1 user (show)

Fixed In Version: R-data.table-1.12.8-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-08 02:01:44 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2019-07-31 16:09 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 16:09 UTC, Fedora Release Engineering
no flags Details
state.log (645 bytes, text/plain)
2019-07-31 16:09 UTC, Fedora Release Engineering
no flags Details


Links
System ID Priority Status Summary Last Updated
Github Rdatatable data.table issues 3863 None closed 1.12.4 release checks 2020-01-30 08:58:22 UTC

Description Fedora Release Engineering 2019-07-31 16:09:02 UTC
R-data.table failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36631746


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix R-data.table at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
R-data.table will be orphaned. Before branching of Fedora 32,
R-data.table will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 16:09:05 UTC
Created attachment 1595257 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2019-07-31 16:09:07 UTC
Created attachment 1595258 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 16:09:09 UTC
Created attachment 1595259 [details]
state.log

Comment 4 Elliott Sales de Andrade 2019-07-31 22:18:48 UTC
*** Bug 1735426 has been marked as a duplicate of this bug. ***

Comment 5 Ben Cotton 2019-08-13 16:59:32 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 18:51:33 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Fedora Release Engineering 2019-09-22 04:23:02 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 31 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 8 Elliott Sales de Andrade 2019-09-22 05:09:33 UTC
1.12.4 is running through final checks before posting to CRAN and should fix most if not all failures.

Comment 9 Elliott Sales de Andrade 2019-10-21 20:07:12 UTC
There are some bugs on s390x that need fixing.

Comment 10 Fedora Update System 2020-01-31 01:30:20 UTC
R-data.table-1.12.8-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e6eca44a62

Comment 11 Fedora Update System 2020-02-08 02:01:44 UTC
R-data.table-1.12.8-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.