This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 173510 - (mesademos) Modular X missing glxgears and glxinfo
Modular X missing glxgears and glxinfo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 174549 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-17 13:35 EST by Brian Gerst
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 04:41:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Gerst 2005-11-17 13:35:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
glxgears and glxinfo are missing from Mesa after modular X upgrades.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Update to modular X

Additional info:
Comment 1 Mike A. Harris 2005-11-19 05:10:20 EST
Thanks for the report.  glxgears and glxinfo are actually part of Mesa,
which used to be imported into the monolithic X tree from the upstream
MesaDemos package.

Most of the MesaDemos programs are unnecessary in Fedora Core, and more
suited for Fedora Extras however.  Sometime before Fedora Core 5 ships,
I'll have to see what the best way to include just these two applications
into our packaging might be, without including the rest of the GL demos.

Perhaps if we're lucky, Brian can be convinced to split them out into
MesaGLapps or something.

Comment 2 Mike A. Harris 2005-11-29 19:27:11 EST
*** Bug 174549 has been marked as a duplicate of this bug. ***
Comment 3 Alistair Riddoch 2006-01-25 21:56:26 EST
The OpenGL man pages have also disappeared during the transition to modular X.
Presumably they were also merged into the X tree from Mesa? I can't find any
trace of them in another package.

Can they also be included in a new package?
Comment 4 Mike A. Harris 2006-02-07 04:41:02 EST
Ok, I tried to create a separate glx-utils src.rpm but that proved to be
futile due to Mesa's enigmatic build process.  Once I realized the insanity
it would entail to make it work, I decided to stuff glxgears/glxinfo into
the Mesa src.rpm as a glx-utils subpackage.  That proved to be much
simpler, and the only downside it caused is an 800Kb increase in the size
of the src.rpm, and about a 4 second increase in the package build time,
so overall a separate glx-utils SRPM was probably a bit of overkill for
anything it would have gained.

The new glx-utils subpackage will be present in Mesa-6.4.2-2 and later in
rawhide, however there are some mesa build problems on ppc currently holding
up new builds from going through.  Once that's fixed, the new build will
hit rawhide.  Hopefully on Wednesday it should show up publically.

Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.