Bug 173514 - RFE: enable dvi support during the fc5 test release phase
RFE: enable dvi support during the fc5 test release phase
Status: CLOSED DUPLICATE of bug 187381
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-17 14:41 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 08:20:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-11-17 14:41:51 EST
enable the 'experimental' dvi support in evince in rawhide through the fc5 test
release process so testers can test and report back with no commitment to leave
dvi enabled in fc5 final release. Then turn dvi support off again at the close
of test phase if dvi is still not good enough to ship in fc5.

-jef
Comment 1 Jef Spaleta 2005-11-23 18:59:22 EST
Additionally id like to point out that tetex-xdvi is one of the few remaining
packages in Core that requires openmotif.  Moving forward towards being able to
move openmotif out of Core has to be an important goal somewhere in the larger
plan for Core. And the only way thats going to happen and keep dvi document
support in Core is to get it turned on in evince and tested.

-jef
Comment 2 Mike A. Harris 2005-11-23 19:04:59 EST
Jef: This sounds like a great idea.  Also, reducing the openmotif dep
count by 1 package would make it easier to transition motif to Fedora
Extras, and out of the Core OS.
Comment 3 Mike A. Harris 2006-02-21 11:00:12 EST
Kristian:

Any opinion on this?  Curious what your thoughts are, etc.

TIA
Comment 4 dann 2006-02-21 12:33:59 EST
Even if evince was to be compiled with xdvi support, evince is NOT a good
replacement for xdvi because it is missing a fundamental feature: support for 
dvi source specials. 

Source specials allow for bidirectional communication between a tex editor and a
dvi viewer, it allows for a dvi document to be opened showing the place in the
dvi document that corresponds to the place where the cursor is in the tex editor
(and the other way around). This support is fundamental for editing tex
documents with hundreds of pages like dissertations, books. Evince does not have
this kind of features.

If the problem is xdvi being linked with motif, then just compile xdvi with
support for another toolkit (like xaw or xaw3d). Replacing xdvi with evince
would be a major inconvenience for the people that actually use xdvi on a daily
basis.
Just my 2 cents.
Comment 5 Rahul Sundaram 2006-02-21 12:43:28 EST
(In reply to comment #4)
> Even if evince was to be compiled with xdvi support, evince is NOT a good
> replacement for xdvi because it is missing a fundamental feature: support for 
> dvi source specials. 
> 
Please file a different RFE on other feature requests. Whether it is going to
replace xdvi or not is not under discussion in this report. That will have to be
decided after we experimentally enable and test this option in a development cycle. 
Comment 6 Deji Akingunola 2007-06-21 19:11:57 EDT
PING !!
I believe the dvi backend is not marked as experimental anymore. 
Comment 7 Jonathan Underwood 2007-11-17 08:20:40 EST
Marking this as a dupe of 187381 (even though this bug was filed first - this is
a subset of 187381.

*** This bug has been marked as a duplicate of 187381 ***

Note You need to log in before you can comment on or make changes to this bug.