This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 187381 - RFE: Build evince with --enable-dvi and --enable-djvu
RFE: Build evince with --enable-dvi and --enable-djvu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: FutureFeature
: 173514 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2006-03-30 12:17 EST by Mariano Suárez-Alvarez
Modified: 2008-02-01 14:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 14:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mariano Suárez-Alvarez 2006-03-30 12:17:08 EST
It really adds to the charm of evince that it is sort of a universal document
viewer. While both DVI and DJVU are not as common as PDF and PS, the support for
them in evince is quite good and does not carry much overweight, so it would be
very, very nice if the FC build included support for them---oh, btw, did I
mention that I spend my days typing LaTeX?

(This does add two dependencies... Maybe upstream would consider turning evince
into a modular thingie, so that formats can be added as plugins. That way the
xdvi package and extras's dvjulibre could drop in corresponding plugins into a
/usr/libexec/evince directory...)
Comment 1 Jonathan Underwood 2007-11-17 08:20:41 EST
*** Bug 173514 has been marked as a duplicate of this bug. ***
Comment 2 Jonathan Underwood 2007-11-17 08:22:35 EST
Fedora 8 is out of the door without DVI support in Evince. Most other distros
have DVI support enabled in Evince. This bug, and related other requests for DVI
support have recieved no response from the maintainer, despite being filed as
far back as FC5. Please turn on dvi support in Evince.
Comment 3 Matthias Clasen 2007-11-17 19:38:24 EST
This will add some extra dependencies to evince, and from my quick testing, at
least the djvu backend does not handle zooming correctly, but in principle, I
think it is a good idea to enable these backends. I'll talk to Kristian about it.
Comment 4 Matěj Cepl 2007-11-19 04:19:15 EST
Moreover, if we want to impress people around universities need to use xdvi in
Gnome makes kind of "yuck" user experience. I have no idea about djvu.
Comment 5 Matthias Clasen 2007-11-19 18:20:41 EST
I have asked for splitting djvulibre-libs off the main package here:
https://bugzilla.redhat.com/show_bug.cgi?id=391201
Comment 6 Matthias Clasen 2007-11-19 22:53:21 EST
So, I tried to build with --enable-dvi and --enable-djvu, but the build fails on
x86_64 with some linker error:

libkpathsea.a(tex-file.o): relocation R_X86_64_32S against `kpse_format_info'
can not be used when making a shared object; recompile with -fPIC

So this will have to wait until the switchover to texlive happens, which will ship  
a shared kpathsea library.
Comment 7 Nicola Soranzo 2007-12-14 10:29:18 EST
(In reply to comment #6)
> So this will have to wait until the switchover to texlive happens, which will
ship  
> a shared kpathsea library.

Now texlive is in rawhide, so can you try again?
Comment 8 Hans de Goede 2008-01-30 06:26:23 EST
If I'm not mistaken evince as currently in rawhide has dvi and djvu enabled, so
this should be closed I think.
Comment 9 Mariano Suárez-Alvarez 2008-01-30 19:13:57 EST
Cool. And the latest evince (I don't know if rawhide is that recent) does
implement plugins, too.

Comment 10 Matthias Clasen 2008-02-01 14:43:21 EST
Yeah, there are evince-dvi and evince-djvu subpackages now, which isolate the
main evince package from troublesome dependencies.

Note You need to log in before you can comment on or make changes to this bug.