Bug 173478 - (gccmakedep-missing) gccmakedep missing from imake
gccmakedep missing from imake
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imake (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
: 173568 (view as bug list)
Depends On:
Blocks: FC5Blocker xorg-modular
  Show dependency treegraph
 
Reported: 2005-11-17 08:52 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 07:30:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-11-17 08:52:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
/usr/share/X11/config/Imake.tmpl references gccmakedep, which is missing from the imake package:
#define DependCmd gccmakedep
#define DependCmd $(DEPENDSRC)/gccmakedep

# rpm -qpl imake-0.99.2-4.i386.rpm | grep gccmakedep
#


Version-Release number of selected component (if applicable):
imake-0.99.2-4

How reproducible:
Always

Steps to Reproduce:
1. for i in `rpm -ql imake`; do grep gccmakedep $i && echo $i; done
2. rpm -qpl imake-0.99.2-4.i386.rpm | grep gccmakedep
3.
  

Additional info:

I can't rebuild p.e. x3270 until this is fixed
Comment 1 Mike A. Harris 2005-11-17 12:05:26 EST
Please file a bug in xorg bugzilla at http://bugs.freedesktop.org in the "xorg"
component, indicating that X11R7 RC2 did not come with gccmakedep.  Once it
is autotooled and packaged upstream, I'll add it to a future imake package
build.
Comment 2 Nalin Dahyabhai 2005-11-18 12:13:41 EST
It may just be a misconfiguration -- the package includes "makedepend" which
performs more or less the same function.
Comment 3 Karsten Hopp 2005-11-21 04:47:47 EST
re comment #2: if the wrapper gccmakedep is gone on purpose, then the Imake.tmpl
file should be changed
Comment 4 Mike A. Harris 2005-11-21 17:54:33 EST
(In reply to comment #3)
> re comment #2: if the wrapper gccmakedep is gone on purpose, then the Imake.tmpl
> file should be changed

It was an unintentional omission by X.Org upstream.  All development
takes place in the monolithic source tree still.  The modular cvs contains
only the autotooling build files, and some scripts.  The scripts create
symbolic links from a checkout of the monolithic tree into a special
directory layout, which is used to build the modular tree.  This was
created both by automation, and hand tweaked, however it is still not
100% perfect.  There are about 4 things missing still in modular X that
are present in monolith.

These will be present in X11R7, they're just not available in modular
form yet.  Recommendation for now, is to try "makedepend" and see if it
suffices if you need to build something badly.  Or wait until after
RC3 is out, which should probably have gccmakedep.

HTH
Comment 5 Mike A. Harris 2005-11-22 22:56:10 EST
*** Bug 173568 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2005-12-21 07:30:52 EST
gccmakedep was added to upstream X11R7 RC4 release, and is present in our
imake 1.0.0 package for about a week..  closing as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.