Bug 173629 - Unable to change to UK keyboard settings
Unable to change to UK keyboard settings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC5Blocker xorg-modular
  Show dependency treegraph
 
Reported: 2005-11-18 14:05 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 12:06:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-11-18 14:05:56 EST
Description of problem:
After the big update to the modular xorg-x11, my keyboard has reverted to US
rather than the UK configuration. If I run the keyboard set application, all I
get is an error

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""



Expected results:
I should be able to set the keyboard correctly

Additional info:
Comment 1 Sander Hoentjen 2005-11-22 14:34:02 EST
In my case I can reproduce by doing:
System > Preferences > Keyboard
tab "Layout Options"
Miscellaneous compat. options
Specials Keys handles in a server.
i then get 3 error dialogs and when i log out i cannot log in again
removing ~/.gconf/desktop/gnome/peripherals/keyboard/kbd/%gconf.xml lets
me log in again

_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us_intl", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us_intl", "", ""
Comment 2 Paul F. Johnson 2005-11-22 14:59:53 EST
avahi makes no difference - I have version 0.5.2-7 installed
Comment 3 Andy Burns 2005-12-01 08:56:11 EST
I issue where UK keyboard chosen during anaconda only applied to text consoles
not to xorg, I corrected that by hand editing /etc/X11/xorg.conf
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "gb"
EndSection

A few days later I noticed that once in xorg I couldn't access virtual consoles
with CTRL-ALT-F1 etc, first I suspected my USB KVM, so moved keyboard to be
directly connected to PC, no different, then I put keyboard settings back to US,
restarted xorg and virtual consoles were working, the gnome
Desktop/Preferences/Keyboard and Desktop/Administration/Keyboard options don't
allow me to change back to a UK layout, I tried using keyboard model "Compaq
easy access keyboard" which is the correct model for my keybaord but then I got
an error dialog

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
69999902

If you report this situation as a bug, please include:

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model = compaqeak8
 overrideSettings = true
 options = []

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

# dmesg | grep -2i chicony
hub 2-2:1.0: 4 ports detected
usb 3-1: new low speed USB device using uhci_hcd and address 2
input: CHICONY Compaq USB Keyboard as /class/input/input2
input: USB HID v1.10 Keyboard [CHICONY Compaq USB Keyboard] on usb-0000:00:1d.2-1
input: CHICONY Compaq USB Keyboard as /class/input/input3
input,hiddev96: USB HID v1.10 Device [CHICONY Compaq USB Keyboard] on
usb-0000:00:1d.2-1
usb 4-1: new full speed USB device using uhci_hcd and address 2

So I changed back to "Generic 105 key intl" 

In keyboard preferences "US English" is the default, I have a button to remove
that, but the button to Add another layout is greyed out.

I am up to date with rawhide, any suggestions to fix, or more information
required that will be helpful?
Comment 4 Paul F. Johnson 2005-12-01 09:30:39 EST
It seems to be sort of fixed in the current rawhide. By sort of, I mean that if
I set the keyboard using Gnome, I get a message asking me if I want to use the
xorg keyboard or Gnome one - I choose gnome and all is well with the world. It
looks like xorg may still be bust, but gnome is fixing the problem!
Comment 5 Andy Burns 2005-12-01 09:49:31 EST
Yes, rawhide 20051201 became available a few minutes after my last comment, I've
upgraded to that and I now have a UK layout with working virtual consoles, so
that is good.

I remember that I got the "use xorg or gnome settings" question when I first
installed, can't remember what I answered though.

However if I change the model from pc105 to compaqeak8 I still get the error
"Error activating XKB configuration"

I'm not sure if I would get any benefit from the 8 "easy access" keys even if I
had them, I tend to ignore they're even there, I didn't even realise xorg would
be interested in them, perhaps some people have a use for them?


Note You need to log in before you can comment on or make changes to this bug.