Bug 173665 - package attempts to replace a directory with a symlink
package attempts to replace a directory with a symlink
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xbitmaps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: FC5Blocker xorg-modular
  Show dependency treegraph
 
Reported: 2005-11-18 15:44 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 10:21:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2005-11-18 15:44:44 EST
Description of problem:
Installing xorg-x11-xbitmaps on a system with openmotif previously-installed
breaks because openmotif puts files in /usr/include/X11/bitmaps/, causing
/usr/include/X11/bitmaps to be a directory.

Version-Release number of selected component (if applicable):
0.99.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install openmotif 2.2.3-14
2. Attempt to install xorg-x11-xbitmaps
  
Actual results:
error: unpacking of archive failed on file /usr/include/X11/bitmaps: cpio:
rename failed - Is a directory
Comment 1 Mike A. Harris 2005-11-21 16:32:45 EST
openmotif is about to lose bigtime.  <grin>

It should put it's files in it's own directory, say /usr/include/Xm or
/usr/include/not-X11, to maximize compatibility in the future by keeping
it's own namespace.

New X packages are going to force this problem to go away, but in the
process, will break any package already installed which put files in
X's include dir.

<cartman>Bad openmotif!  That's a bad openmotif!</cartman>

Theoretically fixed packages in dist-fc5-HEAD, but they wont hit the
buildroot until the tree becomes unlocked and they hit dist-fc5, as
the buildroot doesn't look in -HEAD.

I'll update this again, once we have things in the right place.
Comment 2 Mike A. Harris 2005-11-23 10:14:39 EST
This problem should be resolved now with the following packages installed:

xorg-x11-filesystem >= 0.99.2-3
filesystem-2.3.7-1
xorg-x11-bitmaps >= 0.99.1-4


IMPORTANT NOTE:  As mentioned above, there is a caveat to this solution,
which is that packages that have installed their files into X.Org owned
directories, while there was a symlink in the path, will now have to
be reinstalled.  There may be rpm installed files left behind afterward
as well.  Such is rawhide...

Setting status to "RAWHIDE"


Note You need to log in before you can comment on or make changes to this bug.