Bug 173728 - screen artifacts with icons on desktop and in toolbars
screen artifacts with icons on desktop and in toolbars
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-19 14:43 EST by Willem Riede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 05:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot demonstrating problem (126.03 KB, image/png)
2005-11-19 14:45 EST, Willem Riede
no flags Details
xorg startup log (65.45 KB, text/plain)
2005-11-19 14:46 EST, Willem Riede
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5108 None None None Never

  None (edit)
Description Willem Riede 2005-11-19 14:43:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
On my opteron with ATI Radeon X300SE icons are displayed incorrectly placed initially and differently on mouse-over. See attached screenshot and Xorg log.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7-1

How reproducible:
Always

Steps to Reproduce:
1.upgrade to today's (11/19) rawhide
2.start gnome and login
3.move mouse over all icons
  

Actual Results:  garbage appears - look at attached screenshot on desktop and panel at top left

Expected Results:  screen should have stayed clean with all icons properly placed

Additional info:
Comment 1 Willem Riede 2005-11-19 14:45:29 EST
Created attachment 121269 [details]
Screenshot demonstrating problem
Comment 2 Willem Riede 2005-11-19 14:46:28 EST
Created attachment 121270 [details]
xorg startup log
Comment 3 Mike A. Harris 2005-11-19 23:50:38 EST
Please report this problem to the upstream X.Org bugzilla, located at
"http://bugs.freedesktop.org" in the "xorg" component.  Attach your X server
log file and config file to the X.Org report, and possibly the screenshot
as well.  Mark the bug as blocking bug #1690, which is the release blocker,
in order to have the issue prioritized for review.

Once you've filed your bug report there, the people maintaining the driver
will be able to investigate and troubleshoot the problem.  If you paste the
URL to your X.Org bug report here, Red Hat will track the upstream X.Org
bug report, and will review any patches that become available for
consideration in future builds.
Comment 4 Mike A. Harris 2005-11-19 23:51:53 EST
Setting status to "NEEDINFO_REPORTER", and awaiting upstream bug report
URL for tracking.
Comment 5 Willem Riede 2005-11-20 12:21:46 EST
Done: Bug 5108
Comment 6 Mike A. Harris 2005-11-23 00:42:40 EST
http://freedesktop.org/bugzilla/show_bug.cgi?id=5108
Comment 7 Frank Arnold 2006-01-26 08:06:05 EST
Seems to be fixed:
http://freedesktop.org/bugzilla/show_bug.cgi?id=3944
Comment 8 Mike A. Harris 2006-02-07 05:21:39 EST
This should be fixed already in xorg-x11-server-1.0.1 and later, as Soeren's
patch is present in that release.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.