Bug 173734 - emacs won't start with modular X: Undefined color: "black"
emacs won't start with modular X: Undefined color: "black"
Status: CLOSED DUPLICATE of bug 173428
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 175222 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-19 19:48 EST by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-20 03:27:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Dickson 2005-11-19 19:48:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
When I enter the command "emacs" on the terminal, I get the following:

Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Undefined color: "black"

And then get the next command prompt.

Emacs load and runs on the console (no X environment).

strace of emacs shows emacs is still accessing /usr/X11R6 for locale.alias.

Version-Release number of selected component (if applicable):
emacs-21.4-8

How reproducible:
Always

Steps to Reproduce:
1. type emacs at a gnome-terminal window.

  

Actual Results:  [dickson@white 17:45:24 RT2]$ emacs
Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Undefined color: "black"
[dickson@white 17:45:25 RT2]$


Expected Results:  emacs should have opened a window,

Additional info:
Comment 1 Paul Dickson 2005-11-20 01:52:54 EST
The RbgPath definition was deleted by xorg-x11-server-0.99.3-6 from my xorg.conf
file.

I created the file (backed up from eariler, and added back the RgbPath
definition.  Emacs now runs.
Comment 2 Paul Dickson 2005-11-20 02:19:37 EST
I believe I did this to myself.  I moved, rather than copied,
/usr/lib/X11/rgb.txt.  

Reinstalling xorg-x11-server-utils and deleting the RgbPath reference solves my
problem.

Xmms's buttons are the right color too, now.
Comment 3 Jens Petersen 2005-11-20 03:27:29 EST

*** This bug has been marked as a duplicate of 173453 ***
Comment 4 Jens Petersen 2005-11-21 02:26:03 EST

*** This bug has been marked as a duplicate of 173428 ***
Comment 5 Jens Petersen 2005-12-12 03:10:16 EST
*** Bug 175222 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.