Bug 1737621 - Keystone process is launched with multiple '-DFOREGROUND'.
Summary: Keystone process is launched with multiple '-DFOREGROUND'.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: 15.0 (Stein)
Assignee: RHOS Maint
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On: 1737366
Blocks: 1737623 1737624
TreeView+ depends on / blocked
 
Reported: 2019-08-05 21:10 UTC by Nathan Kinder
Modified: 2019-09-27 10:44 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190826150036.30390bc.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1737366
: 1737623 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:24:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 674554 0 None MERGED keystone: drop duplicate -DFOREGROUND 2020-01-30 15:28:45 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:41 UTC

Description Nathan Kinder 2019-08-05 21:10:51 UTC
+++ This bug was initially created as a clone of Bug #1737366 +++

Description of problem:
Keystone process is launched with multiple '-DFOREGROUND'.

A sample process status:

root           1       0  0 Jul26 ?        00:00:26 /usr/sbin/httpd -DFOREGROUND -DFOREGROUND
keystone      18       1  0 Jul26 ?        00:04:33 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      19       1  0 Jul26 ?        00:04:32 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      20       1  0 Jul26 ?        00:04:31 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      21       1  0 Jul26 ?        00:04:30 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      22       1  0 Jul26 ?        00:04:39 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      23       1  0 Jul26 ?        00:04:36 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      24       1  0 Jul26 ?        00:04:28 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      25       1  0 Jul26 ?        00:04:25 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      26       1  0 Jul26 ?        00:04:33 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      27       1  0 Jul26 ?        00:04:33 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      28       1  0 Jul26 ?        00:04:32 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      29       1  0 Jul26 ?        00:04:34 keystone-admin  -DFOREGROUND -DFOREGROUND

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Deploy overcloud with RHOSP13z7.
2. Check process information on a controller node.
3.

Actual results:
keystone process is launched with multiple '-DFOREGROUND'.

Expected results:
The process is launched with a single '-DFOREGROUND'.

Additional info:
Upstream Launchpad: https://bugs.launchpad.net/tripleo/+bug/1832090
Gerrit: https://review.opendev.org/#/c/664135/

--- Additional comment from Nathan Kinder on 2019-08-05 21:06:40 UTC ---

QE verification steps:

- Deploy OSP (deplolyment topology/details are not important.  You just need 1 controller with Keystone.)
- Run 'ps -ef | grep keystone' on the overcloud controller to confirm that "-DFOREGROUND" is specified only once per keystone process.

Comment 8 errata-xmlrpc 2019-09-21 11:24:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.