Bug 1737624 - Keystone process is launched with multiple '-DFOREGROUND'.
Summary: Keystone process is launched with multiple '-DFOREGROUND'.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
low
low
Target Milestone: z9
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On: 1737366 1737621 1737623
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-05 21:15 UTC by Nathan Kinder
Modified: 2020-03-11 14:57 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.3.1-92.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1737623
Environment:
Last Closed: 2019-11-07 14:01:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 677430 None MERGED keystone: drop duplicate -DFOREGROUND 2020-03-11 14:56:04 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:02:01 UTC

Description Nathan Kinder 2019-08-05 21:15:26 UTC
+++ This bug was initially created as a clone of Bug #1737623 +++

+++ This bug was initially created as a clone of Bug #1737621 +++

+++ This bug was initially created as a clone of Bug #1737366 +++

Description of problem:
Keystone process is launched with multiple '-DFOREGROUND'.

A sample process status:

root           1       0  0 Jul26 ?        00:00:26 /usr/sbin/httpd -DFOREGROUND -DFOREGROUND
keystone      18       1  0 Jul26 ?        00:04:33 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      19       1  0 Jul26 ?        00:04:32 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      20       1  0 Jul26 ?        00:04:31 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      21       1  0 Jul26 ?        00:04:30 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      22       1  0 Jul26 ?        00:04:39 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      23       1  0 Jul26 ?        00:04:36 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      24       1  0 Jul26 ?        00:04:28 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      25       1  0 Jul26 ?        00:04:25 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      26       1  0 Jul26 ?        00:04:33 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      27       1  0 Jul26 ?        00:04:33 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      28       1  0 Jul26 ?        00:04:32 keystone-admin  -DFOREGROUND -DFOREGROUND
keystone      29       1  0 Jul26 ?        00:04:34 keystone-admin  -DFOREGROUND -DFOREGROUND

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Deploy overcloud with RHOSP13z7.
2. Check process information on a controller node.
3.

Actual results:
keystone process is launched with multiple '-DFOREGROUND'.

Expected results:
The process is launched with a single '-DFOREGROUND'.

Additional info:
Upstream Launchpad: https://bugs.launchpad.net/tripleo/+bug/1832090
Gerrit: https://review.opendev.org/#/c/664135/

--- Additional comment from Nathan Kinder on 2019-08-05 21:06:40 UTC ---

QE verification steps:

- Deploy OSP (deplolyment topology/details are not important.  You just need 1 controller with Keystone.)
- Run 'ps -ef | grep keystone' on the overcloud controller to confirm that "-DFOREGROUND" is specified only once per keystone process.

Comment 7 errata-xmlrpc 2019-11-07 14:01:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.