Bug 173763 - /bin/su doesn't work inside gnome-terminal/xterm.
/bin/su doesn't work inside gnome-terminal/xterm.
Status: CLOSED DUPLICATE of bug 173939
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 14:40 EST by Rob Andrews
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 12:11:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Andrews 2005-11-20 14:40:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
/bin/su doesn't work from gnome-terminal (or xterm, for that matter). Works okay from a virtual console.

No messages are reported, but strace reveals:

[snip]
read(3, "#%PAM-1.0\nauth     required     "..., 4096) = 154
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0xb7f7d000, 4096)                = 0
getuid32()                              = 500
ioctl(0, SNDCTL_TMR_TIMEBASE or TCGETS, 0xbfb7bb98) = -1 ENOTTY (Inappropriate ioctl for device)
write(2, "standard in must be a tty\n", 26) = 26
close(1)                                = 0
munmap(0xab1000, 9680)                  = 0
exit_group(1)                           = ?
Process 16114 detached

The 'standard in must be a tty' being the line that gives it away.

Version-Release number of selected component (if applicable):
coreutils-5.93-2

How reproducible:
Always

Steps to Reproduce:
1. Run gnome-terminal/xterm/possibly other terminals
2. Run /bin/su -
3. Wail in despair at the fact that you cannot become root

Actual Results:  Had to wipe the tears a little, but otherwise, nothing.

Expected Results:  Should have prompted for password.

Additional info:
Comment 1 Tim Waugh 2005-11-21 04:50:35 EST
Works for me.  What does 'tty' say in the same context?
Comment 2 Tim Waugh 2005-12-02 12:11:02 EST

*** This bug has been marked as a duplicate of 173939 ***

Note You need to log in before you can comment on or make changes to this bug.