Bug 173788 - kedit segfaults with scim-qtimm
kedit segfaults with scim-qtimm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-qtimm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2005-11-21 01:25 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: scim-qtimm-0.9.4-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 04:22:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-11-21 01:25:04 EST
Description of problem:
Tried to activate SCIM in kedit and application crash as a result.

Version-Release number of selected component (if applicable):
scim-1.4.2-6

How reproducible:
Always

Steps to Reproduce:
1.LANG=ko_KR.UTF-8 kedit
2.ctrl-space to activate LE
3.
  
Actual results:
Application crash

Expected results:
Should not crash

Additional info:
The warning mentioned something about a global file but I dont have it in my
.scim dir.

Detaching after fork from child process 7555.
kbuildsycoca running...
ScimInputContextPlugin()
~ScimInputContextPlugin()
ScimInputContextPlugin()
WARNING: please edit ~/.scim/global and change /DefaultConfigModule to kconfig

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208703312 (LWP 7552)]
0x008593e2 in ?? ()
    at
/usr/lib/gcc/i386-redhat-linux/4.0.2/../../../../include/c++/4.0.2/bits/vector.tcc:127
   from /usr/lib/libscim-1.0.so.8
127           return __first;
Current language:  auto; currently c++
Comment 1 Lawrence Lim 2005-11-21 01:26:13 EST
Hope this helps.


(gdb) bt
#0  0x008593e2 in ?? ()
    at
/usr/lib/gcc/i386-redhat-linux/4.0.2/../../../../include/c++/4.0.2/bits/vector.tcc:127
   from /usr/lib/libscim-1.0.so.8
#1  0x0087f7be in ?? ()
    at
/usr/lib/gcc/i386-redhat-linux/4.0.2/../../../../include/c++/4.0.2/bits/vector.tcc:127
   from /usr/lib/libscim-1.0.so.8
#2  0x0087bc09 in ?? ()
    at
/usr/lib/gcc/i386-redhat-linux/4.0.2/../../../../include/c++/4.0.2/bits/vector.tcc:127
   from /usr/lib/libscim-1.0.so.8
#3  0x0087bc33 in ?? ()
    at
/usr/lib/gcc/i386-redhat-linux/4.0.2/../../../../include/c++/4.0.2/bits/vector.tcc:127
   from /usr/lib/libscim-1.0.so.8
#4  0x00272e18 in scim::SocketInstance::do_transaction (this=0x8937248,
trans=@0xbf96c6dc,
    ret=@0xbf96c6a9) at scim_socket_imengine.cpp:902
#5  0x002765f8 in scim::SocketInstance::commit_transaction (this=0x8937248,
trans=@0xbf96c6dc)
    at scim_socket_imengine.cpp:829
#6  0x002774de in scim::SocketInstance::process_key_event (this=0x8937248,
key=@0xbf96c748)
    at scim_socket_imengine.cpp:643
#7  0x0025bf8b in scim::QScimInputContext::filterScimEvent (this=0x8841830,
key=@0xbf96c748)
    at qsciminputcontext.cpp:940
#8  0x0025c04e in scim::QScimInputContext::x11FilterEvent (this=0x8841830,
event=0xbf96ca08)
    at qsciminputcontext.cpp:720
#9  0x00193548 in QMultiInputContext::x11FilterEvent ()
   from /usr/lib/qt-3.3/plugins/inputmethods/libqimsw-multi.so
#10 0x021d7e91 in QApplication::x11ProcessEvent () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x021ecc62 in QEventLoop::processEvents () from
/usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x0225ba8b in QEventLoop::enterLoop () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x0225b996 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x02242cb9 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x0012e7b7 in kdemain () from /usr/lib/libkdeinit_kedit.so
#16 0x00ad750f in __libc_start_main () from /lib/libc.so.6
#17 0x08048555 in ?? ()
Comment 2 Jens Petersen 2005-11-21 01:57:11 EST
Thanks for reporting this.
Comment 3 Jens Petersen 2005-12-19 03:46:58 EST
This seems to be fixed now in rawhide after the latest rebuilds AFAICT.
Comment 4 Lawrence Lim 2005-12-19 04:22:44 EST
Confirmed fixed with scim-qtimm-0.9.4-2.1. I noticed a warning message while
kedit loads. 

ScimInputContextPlugin()
WARNING: please edit ~/.scim/global and change /DefaultConfigModule to kconfig
Comment 5 Jens Petersen 2005-12-19 05:47:17 EST
I think that warning is for the benefit of KDE and skim users.

Note You need to log in before you can comment on or make changes to this bug.