Bug 1738360 - Help prompt for 'Pull Secret' on openshift-install points to an invalid URL
Summary: Help prompt for 'Pull Secret' on openshift-install points to an invalid URL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: All
low
low
Target Milestone: ---
: 4.3.0
Assignee: Abhinav Dahiya
QA Contact: gaoshang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-06 23:57 UTC by Katherine Dubé
Modified: 2020-01-23 11:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1738339
Environment:
Last Closed: 2020-01-23 11:05:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2582 None None None 2019-10-30 21:19:48 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:05:16 UTC

Description Katherine Dubé 2019-08-06 23:57:22 UTC
+++ This bug was initially created as a clone of Bug #1738339 +++

Description of problem:

The help prompt'Pull Secret' on openshift-install points to an invalid URL after redesign of cloud.redhat.com. 

Should now point to cloud.redhat.com instead of cloud.openshift.com and can no longer use the #pull-secret href index tag: 

--> https://cloud.redhat.com/openshift/install

Any other URL pointers should be updated to new location.


Version-Release number of selected component (if applicable): 4.1.0


How reproducible: 100%


Steps to Reproduce:
1. Use openshift-install to create a cluster 
2. When prompted for 'Pull Secret' press '?" for help

Actual results:

$ ./openshift-install create cluster
? SSH Public Key /Users/bob/.ssh/id_rsa.pub
? Platform aws
? Region us-east-1
? Base Domain devcluster.openshift.com
X Sorry, your reply was invalid: Value is required
? Cluster Name testcluster
? Pull Secret [? for help]
? The container registry pull secret for this cluster, as a single line of JSON (e.g. {"auths": {...}}).

You can get this secret from https://cloud.openshift.com/clusters/install#pull-secret
? Pull Secret


Expected results:

$ ./openshift-install create cluster
? SSH Public Key /Users/bob/.ssh/id_rsa.pub
? Platform aws
? Region us-east-1
? Base Domain devcluster.openshift.com
X Sorry, your reply was invalid: Value is required
? Cluster Name testcluster
? Pull Secret [? for help]
? The container registry pull secret for this cluster, as a single line of JSON (e.g. {"auths": {...}}).

You can get this secret from https://cloud.redhat.com/openshift/install
? Pull Secret


Additional info:

Comment 1 W. Trevor King 2019-10-30 21:15:43 UTC
Removed the blocker to make the Bugzilla not happy.

Comment 3 gaoshang 2019-10-31 12:26:49 UTC
This bug has been verified and passed on OCP 4.3.0-0.nightly-2019-10-31-072219, move status to VERIFIED.

Version-Release:
4.3.0-0.nightly-2019-10-31-072219
# ./openshift-install version
./openshift-install v4.3.0
built from commit f2ac89df630f6ae6efb91e8a6f01c5a120389942
release image registry.svc.ci.openshift.org/ocp/release@sha256:c56871c1476c4348215814b30ff58065678e35cf72b0ea3689ef3e85d6b15f50

Steps:
1. Use openshift-install to create a cluster
2. When prompted for 'Pull Secret' press '?" for help
# ./openshift-install create cluster
? SSH Public Key /root/.ssh/openshift-dev.pub
? Platform aws
? Region us-east-2
? Base Domain qe.devcluster.openshift.com
? Cluster Name sgao-cluster
? The container registry pull secret for this cluster, as a single line of JSON (e.g. {"auths": {...}}).

You can get this secret from https://cloud.redhat.com/openshift/install/pull-secret
? Pull Secret

Comment 5 errata-xmlrpc 2020-01-23 11:05:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.