Bug 173864 - Blowfish support in anaconda auth_gui.py and userauth_text.py in addition to md5
Blowfish support in anaconda auth_gui.py and userauth_text.py in addition to md5
Status: CLOSED DUPLICATE of bug 173863
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
Depends On: 173002
  Show dependency treegraph
Reported: 2005-11-21 18:27 EST by Eric Moret
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-24 05:17:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Moret 2005-11-21 18:27:35 EST
Description of problem:

This bug is opened in relation to a feature request for support of blowfish
crypt in shadow/passwd files. Anaconda should allow users to select blowfish for
password encryption method in addition to md5 and regular unix crypt.

Cf: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=173002
Comment 1 Jeremy Katz 2005-11-21 18:33:48 EST
Anaconda isn't going to ask the user what they want to use to encrypt passwords.
 That's completely unreasonable for a user to figure out what the right answer is.

We should pick a sane default and then anaconda will use whatever that default is.
Comment 2 Eric Moret 2005-11-21 21:12:23 EST
Sorry, I am not that familliar with anaconda screens, I thought you were already
given the option... Looking at anaconda's code there seem to be a couple classes
for  asking the question:
/usr/lib/anaconda/iw/auth_gui.pyc - AuthWindow 
/usr/lib/anaconda/textw/userauth_text.py - AuthConfigWindow

I also noticed that firstboot shows a "Use Network Login..." button on the
"System User" screen. When clicked it seems authconfig-gtk is started and not a
specific firstlogin screen. What happens when/if a user was to select blowfish
in the Authentication tab of authconfig-gtk? Would firstboot be able to blowfish
encrypt the password properly with no change or shall I open a feature request
Comment 3 Tomas Mraz 2005-11-23 04:23:18 EST

*** This bug has been marked as a duplicate of 173863 ***
Comment 4 Eric Moret 2005-11-23 11:47:26 EST
Bugzilla 173864 was opened against anaconda with an additional question 
regarding firstboot package see Comment #2 above. It was marked as a duplicate 
of 173863 which deals with authconfig, a different component. I don't see how 
173864 can be a duplicate of 1738643 if they address different components? Do 
you not think anaconda should be updated? In that case could you please answer 
the above firstboot component question (Comment #2)?
Comment 5 Tomas Mraz 2005-11-24 05:17:25 EST
It was reassigned to authconfig by Jeremy.

Firstboot calls system utilities for setting the password so it should be fine.

*** This bug has been marked as a duplicate of 173863 ***

Note You need to log in before you can comment on or make changes to this bug.