Bug 173899 - [bn_IN] Incorrect rendering of two special symbols when used after certain consonant conjuncts in KDE editors
[bn_IN] Incorrect rendering of two special symbols when used after certain co...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: qt (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
desktop-bugs@redhat.com
: i18n, Reopened
Depends On:
Blocks: 214371
  Show dependency treegraph
 
Reported: 2005-11-22 07:15 EST by Runa Bhattacharjee
Modified: 2013-03-03 21:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 06:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incorrect and correct display of the conjuncts (49.32 KB, image/png)
2006-11-13 05:36 EST, Runa Bhattacharjee
no flags Details

  None (edit)
Description Runa Bhattacharjee 2005-11-22 07:15:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
Incorrect rendering of two special symbols ং (U0982) and ঃ (U0983) when used after the consonant conjuncts comprising of the alphabet র (U09B0) + <any other consonant> + <any dependent vowel>.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in to the bn_IN locale
2. Open kwrite
3. Change input method using Ctrl+Space, Change to phonetic layout using F6
4. Type: r/kaL <see picture bn-kde-bug1b>
5. Type: r/kaH <see picture bn-kde-bug2b>
  

Actual Results:  The consonant conjunct+dependent vowel should make a complete combination and the special symbol ought to be displayed after the combination.

Expected Results:  Instead the special character squeezed itself between the consonant conjunct and dependent vowel combination. < see pictues: bn-kde-bug1a & bn-kde-bug2a>

Additional info:
Comment 1 Lawrence Lim 2006-09-27 20:27:10 EDT
Is this still an issue in our rawhide distribution??
Comment 2 Runa Bhattacharjee 2006-09-28 07:30:27 EDT
The problem still persists in rawhide.
Comment 3 Lawrence Lim 2006-11-07 02:51:42 EST
This is not the proper way to resolve RHEL4 bug.
Comment 4 Satyabrata Maitra 2006-11-07 04:47:18 EST
It seems that output of the given char combination in RHEL5 Beta, is showing
wrong, but I would like to see the attachment of the screenshot of erroneous
char combinations observed as the given pictures can not be opened ever.

** Screenshot file name should not contain the word "bug1" "bug2" as it creates
link autometically by Bugzilla itself. so, Please put .jpg or .png extension in
the file name and attach it in proper way with this bug.
Comment 5 Runa Bhattacharjee 2006-11-13 05:36:02 EST
Created attachment 141034 [details]
incorrect and correct display of the conjuncts

The actual and expected display of the mentioned character combinations along
with the key sequences is depicted in the attached image.
Comment 6 Rahul Bhalerao 2009-03-20 01:43:52 EDT
This bug seems to be fixed in current release of RHEL. Tested on RHEL-5.2. Please confirm and close this bug.
Comment 7 A S Alam 2009-06-11 06:53:51 EDT
Bug is fixed with following version:
qt-3.3.3-16.el4

Test Case (Text):
 ং
ঃ

রং
রঃ

Verified
Comment 8 A S Alam 2009-06-11 06:57:53 EDT
Package available with following release:
Red Hat Enterprise Linux AS release 4 (Nahant Update 8)

Note You need to log in before you can comment on or make changes to this bug.