Bug 173907 - firefox crashes on www.dpreview.com
firefox crashes on www.dpreview.com
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-22 09:51 EST by Vlado Potisk
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-22 12:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2005-11-22 09:51:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Firefox crashes when trying to load http://www.dpreview.com.

Version-Release number of selected component (if applicable):
firefox-1.0.7-1.1.fc4

How reproducible:
Always

Steps to Reproduce:
1. start firefox
2. type this URL: http://www.dpreview.com and press ENTER


Actual Results:  segfault

Expected Results:  requested web page should appear on the display

Additional info:

www.dpreview.com site gets updated from time to time. There were no problems in the past, it started few days ago and maybe the section triggering this crash will disappear again in several days.

Konqueror does not crash.
Comment 1 Vlado Potisk 2005-11-22 10:01:18 EST
I forgot to mention that I'm using i386 firefox version on an x86_64 computer. I
have uninstalled the x86_64 firefox RPM and installed the i386 RPM because the
flash player plugin is available in 32-bit version only. 
Comment 2 Warren Togami 2005-11-22 10:51:17 EST
I am running the exact same firefox version on FC4, and this page doesn't crash
my browser.

Could you please verify that the issue in Bug #155582 is not your problem? 
(Check xorg.conf to see if you have enabled X composite.)
Comment 3 Vlado Potisk 2005-11-22 11:16:27 EST
I have read the bug description and comments, #155582 is not my problem.

I have found something interesting though. When I erase my ~/.mozilla directory,
then there is no crash. When I restore it, the crash is back, so it is obviously
related to the configuration. I will try to investigate further.
Comment 4 Vlado Potisk 2005-11-22 12:14:01 EST
In my opinion there are two problems interacting in a strange way:

problem #1 - [flashblock crash] - the flashblock.xpi (v1.3.2) extension seems to
be the culprit responsible for the crash, uninstalling it solved the problem.

problem #2 - [safe mode bug] - before I filed this bug I ran firefox with the
-safe-mode option in order to rule out a problem with extensions
(http://www.mozilla.org/support/firefox/faq, section Troubleshooting). I have
now realized that all other extensions are disabled in the safe mode, but not
the flashblock.xpi ! (don't ask me why)

Because of the safe mode bug I believed the problem was in the firefox program.
This is not the case, that's why I think this bug should be closed. If you agree
please do so.

(I'd like to thank Warren for the quick response)
Comment 5 Warren Togami 2005-11-22 12:56:08 EST
Thanks.

Note You need to log in before you can comment on or make changes to this bug.