Bug 1739081 - [Regression] DHCPv4 does not work on dnsmasq-2.80-8.fc31
Summary: [Regression] DHCPv4 does not work on dnsmasq-2.80-8.fc31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: 31
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1739797
TreeView+ depends on / blocked
 
Reported: 2019-08-08 12:57 UTC by Gris Ge
Modified: 2019-08-22 01:17 UTC (History)
11 users (show)

Fixed In Version: dnsmasq-2.80-9.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1739797 (view as bug list)
Environment:
Last Closed: 2019-08-22 01:17:20 UTC


Attachments (Terms of Use)

Description Gris Ge 2019-08-08 12:57:40 UTC
Description of problem:

With dnsmasq-2.80-8.fc31, the DHCPv4 does not any more.

And it also generates a flood of RA advertisement.

After downgrade to dnsmasq-2.79-7.fc29, all goes well.


Version-Release number of selected component (if applicable):
dnsmasq-2.80-8.fc31.x86_64

How reproducible:
100%

Steps to Reproduce:

sudo ip link add dhcpcli type veth peer name dhcpsrv
sudo ip link set up dhcpcli
sudo ip netns add nmstate_test
sudo ip link set dhcpsrv netns nmstate_test
sudo ip netns exec nmstate_test ip link set up dhcpsrv
sudo ip netns exec nmstate_test ip addr add 192.0.2.251/24 dev dhcpsrv
sudo ip netns exec nmstate_test \
    dnsmasq --dhcp-range=192.0.2.100,192.0.2.200,255.255.255.0 \
    --interface=dhcpsrv
sudo dhclient -d dhcpcli



Actual results:
DHCPv4 not work

Expected results:
DHCPv4 works

Additional info:

Comment 1 Petr Menšík 2019-08-09 13:08:02 UTC
Ok, confirm it is broken. Not sure yet for right reason. I tried to fix failing build on rawhide by quick support for SO_TIMESTAMP. I think that broken it completely. Would disable it and just skip SIOCGSTAMP if not defined.

Comment 2 Petr Menšík 2019-08-09 13:35:26 UTC
Fixed in commit [1]. But removing SO_TIMESTAMP seems to fixed issue. It seems there is another issue with high CPU usage in all 2.80 versions.

1. https://src.fedoraproject.org/rpms/dnsmasq/c/bde34f977c037ecb05757b5feea0a05ba6c856ae

Comment 3 Chris Murphy 2019-08-10 01:31:51 UTC
I've run into this as well. Rawhide host has no apparent problem; but any qemu-kvm guest has no network connection, because ipv4 isn't being assigned to the guest.

In the working case, I see these lines in the host's journal, when the VM is starting up:
[   99.883685] fmac.local dnsmasq-dhcp[1112]: DHCPDISCOVER(virbr0) 52:54:00:7c:25:f9
[   99.884350] fmac.local dnsmasq-dhcp[1112]: DHCPOFFER(virbr0) 192.168.122.175 52:54:00:7c:25:f9
[   99.884663] fmac.local dnsmasq-dhcp[1112]: DHCPREQUEST(virbr0) 192.168.122.175 52:54:00:7c:25:f9
[   99.884785] fmac.local dnsmasq-dhcp[1112]: DHCPACK(virbr0) 192.168.122.175 52:54:00:7c:25:f9 localhost-live

Those lines don't exist in the non-working case.

Updating to -9 or downgrading to -4 fixes the problem.
https://kojipkgs.fedoraproject.org//packages/dnsmasq/2.80/9.fc31/x86_64/dnsmasq-2.80-9.fc31.x86_64.rpm

Comment 4 Vladimir Benes 2019-08-10 15:00:09 UTC
high cpu usage is filed here: https://bugzilla.redhat.com/show_bug.cgi?id=1739797

Comment 5 Vladimir Benes 2019-08-10 15:00:36 UTC
this bug is fixed by the -9 release

Comment 6 Ben Cotton 2019-08-13 17:10:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Ben Cotton 2019-08-13 17:11:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 8 Fedora Update System 2019-08-13 19:49:08 UTC
FEDORA-2019-c8270fe288 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c8270fe288

Comment 9 Fedora Update System 2019-08-14 01:36:35 UTC
dnsmasq-2.80-9.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c8270fe288

Comment 10 Fedora Update System 2019-08-22 01:17:20 UTC
dnsmasq-2.80-9.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.