Bug 1739797 - [Regression] Hi CPU usage caused by RA flood
Summary: [Regression] Hi CPU usage caused by RA flood
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: 31
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1739081
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-10 14:59 UTC by Vladimir Benes
Modified: 2019-09-14 16:31 UTC (History)
12 users (show)

Fixed In Version: dnsmasq-2.80-10.fc31 dnsmasq-2.80-10.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1739081
Environment:
Last Closed: 2019-09-14 00:06:49 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github InfrastructureServices/dnsmasq-tests/blob/master/bz1739797.sh None None None 2020-02-27 02:47:48 UTC

Description Vladimir Benes 2019-08-10 14:59:19 UTC
I see a huge flood in journalctl from NM, which is probably caused by tons of RA announcements.

Aug 10 10:55:28 testsethostname dnsmasq-dhcp[18631]: RTR-ADVERT(simbr) 2620:52:0:1086::
Aug 10 10:55:28 testsethostname NetworkManager[21459]: <debug> [1565448928.5546] ndisc-lndp[0x55cae74930e0,"eth0"]: processing libndp events
Aug 10 10:55:28 testsethostname dnsmasq-dhcp[18631]: RTR-ADVERT(simbr) 2620:52:0:1086::
Aug 10 10:55:28 testsethostname NetworkManager[21459]: <debug> [1565448928.5548] ndisc-lndp[0x55cae74930e0,"eth0"]: processing libndp events
Aug 10 10:55:28 testsethostname dnsmasq-dhcp[18631]: RTR-ADVERT(simbr) 2620:52:0:1086::
Aug 10 10:55:28 testsethostname NetworkManager[21459]: <debug> [1565448928.5551] ndisc-lndp[0x55cae74930e0,"eth0"]: processing libndp events
Aug 10 10:55:28 testsethostname dnsmasq-dhcp[18631]: RTR-ADVERT(simbr) 2620:52:0:1086::
Aug 10 10:55:28 testsethostname NetworkManager[21459]: <debug> [1565448928.5553] ndisc-lndp[0x55cae74930e0,"eth0"]: processing libndp events


simbr is configured in virtual setup environment used for NetworkManager's tests.
    # Create the 'simbr' - providing both 10.x ipv4 and 2620:52:0 ipv6 dhcp
    ip netns exec vethsetup ip link add name simbr type bridge forward_delay 0 stp_state 1
    ip netns exec vethsetup ip link set simbr up
    ip netns exec vethsetup ip addr add 10.16.1.1/24 dev simbr
    ip netns exec vethsetup ip -6 addr add 2620:52:0:1086::1/64 dev simbr

    # Add eth10 peer into the simbr
    ip netns exec vethsetup ip link set eth10p master simbr

    # Run joint DHCP4/DHCP6 server with router advertisement enabled in veth namespace
    ip netns exec vethsetup dnsmasq --pid-file=/tmp/dhcp_simbr.pid --dhcp-leasefile=/tmp/dhcp_simbr.lease --dhcp-range=10.16.1.10,10.16.1.254,240 --dhcp-range=2620:52:0:1086::10,2620:52:0:1086::1ff,slaac,64,240 --enable-ra --interface=simbr --bind-interfaces

Comment 1 Ben Cotton 2019-08-13 17:04:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 17:10:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Petr Menšík 2019-08-21 17:54:40 UTC
Confirming bug, it is in upstream. Created restartable reproducer [1]. Reliably reports many packets on v2.80, but v2.79 is ok. Vanilla build from upstream is affected too.

1. https://github.com/InfrastructureServices/dnsmasq-tests/blob/master/bz1739797.sh

Comment 4 Petr Menšík 2019-08-21 18:54:11 UTC
Found breaking commit to be [1]. It seems to be intention to send it fast, but maybe damage created was not well considered. Impact is significant.

1. http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=0a496f059c1e9d75c33cce4c1211d58422ba4f62

Comment 5 Petr Menšík 2019-08-21 20:30:50 UTC
Sent information upstream, for now without any patch.

http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2019q3/013255.html

Comment 6 Fedora Update System 2019-08-28 17:56:03 UTC
FEDORA-2019-7f297cb49a has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f297cb49a

Comment 7 Fedora Update System 2019-08-28 17:56:46 UTC
FEDORA-2019-883c54f9e9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-883c54f9e9

Comment 8 Fedora Update System 2019-08-30 00:04:39 UTC
dnsmasq-2.80-10.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7f297cb49a

Comment 9 Fedora Update System 2019-08-30 12:17:07 UTC
dnsmasq-2.80-10.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-883c54f9e9

Comment 10 Fedora Update System 2019-09-14 00:06:49 UTC
dnsmasq-2.80-10.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-09-14 01:12:12 UTC
dnsmasq-2.80-10.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-09-14 16:31:01 UTC
dnsmasq-2.80-10.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.