Bug 1739245 - Applications render as black rectangles when displayed on a remote X display
Summary: Applications render as black rectangles when displayed on a remote X display
Keywords:
Status: CLOSED DUPLICATE of bug 1659927
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-08 20:21 UTC by Carlos Santos
Modified: 2019-08-14 19:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-14 19:31:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
list of installed packages (45.33 KB, text/plain)
2019-08-08 20:32 UTC, Carlos Santos
no flags Details
Screenshot 1 (339.39 KB, image/png)
2019-08-08 20:33 UTC, Carlos Santos
no flags Details
Screenshot 2 (23.45 KB, image/png)
2019-08-08 20:34 UTC, Carlos Santos
no flags Details

Description Carlos Santos 2019-08-08 20:21:57 UTC
Applications render as black rectangles when displayed on a remote X display

Description of problem:

Applications render as black rectangles when displayed on a remote X display
when logging via XDMCP.

Version-Release number of selected component (if applicable):

RHEL7.6 (see installed-rpms.txt attachment)
KVM
QXL display

How reproducible:

Always

Steps to Reproduce:

1. Create two VM's on top of KVM using a bridged virtual network.

2. Install rhel 7.6 on the virtual machines rhel-server-7-6-1 and
   rhel-server-7-6-2

   During the installation, add a user account on rhel-server-7-6-2.

3. Ensure that rhel-server-7-6-{1,2} can ping each other

4. Set rhel-server-7-6-1 default target to multiuser

   # systemctl set-default multi-user.target

5. Set rhel-server-7-6-2 default target to graphical:

   # systemctl set-default graphical.target

6. Configure firewall and GDM on rhel-server-7-6-2 to accept remote access
   via XDMCP as described in https://access.redhat.com/solutions/2736

7. Configure firewall on rhel-server-7-6-1 to accept remote X connections
   as described in the same document

8. Adde a workaround on rhel-server-7-6-2 for the “Authentication required
   to create managed color device” message, as described in

   https://unix.stackexchange.com/questions/417906/authentication-is-required-to-create-a-color-profile

   (I used the /etc/polkit-1/localauthority/50-local.d/color.pkla approach).

9. Restart gdm & polkit on rhel-server-7-6-2

10. Log in as the user added in step 2 on rhel-server-7-6-2, selecting the
    "GNOME" session.

    - Complete the first login steps.
    - Click "Activities" and select "Terminal". A gnome-terminal instance will
      appear.
    - Exit on the terminal
    - Log out

11. Start Xorg on rhel-server-7-6-1 (this might better to do via ssh)

    # Xorg :0 -query rhel-server-7-6-2

    - Log in as the user added in step 2, selecting the "GNOME" session.
    - Click "Activities" and select "Terminal". A gnome-terminal instance will
      appear as a black rectancle (see screenshot 1).
    - Click on the terminal window and hit ^D to exit
    - Log out
    - Stop Xorg when the greeter screen is shown again.

12. Create and alternate non-GNOME session

    - Install motif (for mwm), xorg-x11-apps (for xconsole) and xterm

      # yum install -y motif xorg-x11-apps xterm

    - Create a /usr/share/xsessions/mwm.desktop file containing

      [Desktop Entry]
      Name=MWM
      Comment=This session logs you into the Motif Window Manager
      Exec=mwm
      Type=Application
      DesktopNames=MWM

    - Create a /usr/share/switchdesk/Xclients.mwm file containing

      #!/bin/sh
      #
      # /usr/share/switchdesk/Xclients.mwm
      #
      exec > $HOME/xsession.log 2>&1
      xconsole -file $HOME/xsession.log -exitOnFail -daemon -geometry -1-1
      exec /usr/bin/mwm -multiscreen

      [Do not forget to chmod 755 /usr/share/switchdesk/Xclients.mwm]

11. Start Xorg on rhel-server-7-6-1 acgain

    # Xorg :0 -query rhel-server-7-6-2

    - Log in as the user added in step 2, selecting the "MWM" session.
    - Click with the right button on the background and select "New window" in
      the root menu. A xterm instance will appear.
    - In the xterm promt, run "gnome-terminal". A gnome-terminal will appear
      (see screenshot 2).
    - Exit both terminals
    - Click with the right button on the background and select "Quit..." to
      terminate the session.
    - Stop Xorg when the greeter screen is shown again.

Actual results:

Applications do not render correctly in the GNOME session.

Expected results:

Applications should render correctly in the GNOME session.

Additional info:

Comment 2 Carlos Santos 2019-08-08 20:32:54 UTC
Created attachment 1601934 [details]
list of installed packages

Comment 3 Carlos Santos 2019-08-08 20:33:44 UTC
Created attachment 1601935 [details]
Screenshot 1

Comment 4 Carlos Santos 2019-08-08 20:34:39 UTC
Created attachment 1601936 [details]
Screenshot 2

Comment 5 Matthias Clasen 2019-08-14 19:29:52 UTC
This was caused by a mesa regression that has been reverted.
A yum update should be enough to fix this.

Comment 6 Ray Strode [halfline] 2019-08-14 19:31:50 UTC

*** This bug has been marked as a duplicate of bug 1659927 ***


Note You need to log in before you can comment on or make changes to this bug.