Bug 1739863 - Kernel 5.2+ amdgpu graphics glitches using XFCE
Summary: Kernel 5.2+ amdgpu graphics glitches using XFCE
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-11 10:20 UTC by Bournonville
Modified: 2019-09-04 14:35 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
Dmesg from 5.2.7 kernel boot (103.26 KB, text/plain)
2019-08-11 10:20 UTC, Bournonville
no flags Details
Example image of graphical glitches (3.50 MB, image/jpeg)
2019-08-11 10:22 UTC, Bournonville
no flags Details
Another example image of graphical glitches (3.18 MB, image/jpeg)
2019-08-11 10:23 UTC, Bournonville
no flags Details

Description Bournonville 2019-08-11 10:20:59 UTC
Created attachment 1602586 [details]
Dmesg from 5.2.7 kernel boot

1. Please describe the problem:

My normal desktop is xfce and I run dnf updates daily. After the kernel upgrade to 5.2.5-200, however, using xfce (via LDM) I have consistently experienced graphical 'glitches' whereby parts of the screen are obfuscated by coloured pixels as the pointing device is moved around the desktop. In addition, command output in terminal windows is similarly corrupted. Updates to 5.2.6-200 and today (11th August 2019) to 5.2.7-200 have not changed anything with this regard.  To use xfce without any such graphics issues I need to boot a 5.1 series kernel.

These graphical anomalies were (are) not present using xfce under prior kernels - e.g. 5.1.20-300. 

Other at least some other installed DEs (i.e. Mate or Cinnamon) do <not> exhibit these same graphical anomalies under 5.2+ kernels - only xfce.  Furthermore, my attempt to record the anomalies using simplescreenrecorder resulted in a mkv file that, to my surprise, showed an apparently  'normal' desktop even though the anomalies/artifacts were on the actual monitor screen. 


2. What is the Version-Release number of the kernel:

Kernel 5.2+


3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Worked fine up until: 5.1.20-300.fc30.x86_64

Problem first appeared : 5.2.5-200.fc30.x86_64


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Consistently appears after 5.2+ kernel boot immediately after logging on as any user (including newly created) to a xfce session on my AMD Ryzen 5 2400G powered PC using the onboard graphics (no separate graphics card).


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Not attempted but occurs with three 5.2+ kernels released to date


6. Are you running any modules that not shipped with directly Fedora's kernel?:

Nothing I suspect is relevant. I do not have the xorg-x11-drv-amdgpu rpm installed so using kernel amdgpu driver. 


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Done

--------------------

Other:

https://bugzilla.redhat.com/show_bug.cgi?id=1738650  <may> be related

[testuser@fedorapc ~]$ inxi -Fxxxz
System:
  Host: fedorapc Kernel: 5.2.6-200.fc30.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 9.1.1 Desktop: Gnome 3.32.2 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.28.0, LXDM, SDDM Distro: Fedora release 30 (Thirty) 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X370-PRO v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 5008 date: 06/24/2019 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 2400G with Radeon Vega Graphics 
  bits: 64 type: MT MCP arch: Zen L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 57489 
  Speed: 1516 MHz min/max: 1600/3600 MHz boost: enabled Core speeds (MHz): 
  1: 1516 2: 3791 3: 1516 4: 1786 5: 1517 6: 3784 7: 1511 8: 1956 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 09:00.0 
  chip ID: 1002:15dd 
  Display: x11 server: Fedora Project X.org 1.20.5 driver: ati,modesetting 
  unloaded: fbdev,vesa alternate: amdgpu resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.6-200.fc30.x86_64 LLVM 8.0.0) 
  v: 4.5 Mesa 19.1.3 direct render: Yes 
Audio:
  Device-1: Conexant Systems CX23887/8 PCIe Broadcast Audio and Video 
  Decoder with 3D Comb 
  vendor: Hauppauge works driver: cx23885 v: 0.0.4 bus ID: 05:00.0 
  chip ID: 14f1:8880 
  Device-2: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 09:00.1 chip ID: 1002:15de 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 09:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.2.6-200.fc30.x86_64 
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb 
  v: 5.6.0-k port: e000 bus ID: 07:00.0 chip ID: 8086:1539 
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
  IF-ID-2: virbr0-nic state: down mac: <filter> 
Drives:
  Local Storage: total: 11.37 TiB used: 2.32 TiB (20.4%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 010 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD4005FZBX-00K5WB0 
  size: 3.64 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: 1A01 scheme: GPT 
  ID-3: /dev/sdc vendor: Western Digital model: WD20EARX-32PASB0 
  size: 1.82 TiB speed: 6.0 Gb/s serial: <filter> rev: AB51 scheme: GPT 
  ID-4: /dev/sdd vendor: Western Digital model: WD6003FZBX-00K5WB0 
  size: 5.46 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
  rev: 1A01 scheme: GPT 
Partition:
  ID-1: / size: 449.73 GiB used: 27.86 GiB (6.2%) fs: ext4 dev: /dev/dm-0 
  ID-2: /boot size: 975.9 MiB used: 301.9 MiB (30.9%) fs: ext4 
  dev: /dev/sda2 
  ID-3: /home size: 3.58 TiB used: 667.44 GiB (18.2%) fs: ext4 
  dev: /dev/dm-2 
  ID-4: swap-1 size: 7.40 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 49.4 C mobo: N/A gpu: amdgpu temp: 49 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 310 Uptime: 12m Memory: 13.68 GiB used: 1.56 GiB (11.4%) 
  Init: systemd v: 241 runlevel: 5 target: graphical.target Compilers: 
  gcc: 9.1.1 Shell: bash v: 5.0.7 running in: xfce4-terminal inxi: 3.0.35 


--------------------------------------

[testuser@fedorapc ~]$ sudo lshw -c video
[sudo] password for testuser: 
  *-display                 
       description: VGA compatible controller
       product: Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:09:00.0
       version: c6
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:75 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:d000(size=256) memory:fcd00000-fcd7ffff memory:c0000-dffff


-----------------------

[testuser@fedorapc ~]$ screenfetch
           /:-------------:\          testuser@fedorapc
        :-------------------::        OS: Fedora 30 Thirty
      :-----------/shhOHbmp---:\      Kernel: x86_64 Linux 5.2.6-200.fc30.x86_64
    /-----------omMMMNNNMMD  ---:     Uptime: 15m
   :-----------sMMMMNMNMP.    ---:    Packages: 3831
  :-----------:MMMdP-------    ---\   Shell: bash 5.0.7
 ,------------:MMMd--------    ---:   Resolution: 1920x1080
 :------------:MMMd-------    .---:   DE: XFCE4
 :----    oNMMMMMMMMMNho     .----:   WM: Xfwm4
 :--     .+shhhMMMmhhy++   .------/   WM Theme: Default
 :-    -------:MMMd--------------:    GTK Theme: Adwaita [GTK2]
 :-   --------/MMMd-------------;     Icon Theme: Fedora
 :-    ------/hMMMy------------:      Font: Sans 10
 :-- :dMNdhhdNMMNo------------;       CPU: AMD Ryzen 5 2400G with Radeon Vega Graphics @ 8x 3.6GHz [50.0°C]
 :---:sdNMMMMNds:------------:        GPU: AMD RAVEN (DRM 3.32.0, 5.2.6-200.fc30.x86_64, LLVM 8.0.0)
 :------:://:-------------::          RAM: 1313MiB / 14011MiB
 :---------------------://

Comment 1 Bournonville 2019-08-11 10:22:03 UTC
Created attachment 1602587 [details]
Example image of graphical glitches

Comment 2 Bournonville 2019-08-11 10:23:03 UTC
Created attachment 1602588 [details]
Another example image of graphical glitches

Comment 3 Bournonville 2019-08-11 13:20:05 UTC
Link to short hand-held video of xfce under 5.2.7

https://yadi.sk/i/7rIm90SyzffnHw

Comment 4 Alain Reguera Delgado 2019-08-11 18:22:08 UTC
I am presenting this issue on GNOME Shell 3.32.2, kernel 5.2+, AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx.

This issue is not present when I use kernel-5.0.9-301.fc30.x86_64.

Comment 5 Talha Khan 2019-08-12 17:58:19 UTC
This issue also happens on F30 KDE spin. This has been happening on all versions of kernel 5.2.x. This wasn't happening on kernel 5.1.x
My machine has AMD Ryzen 5 2500U with Radeon Vega Mobile Graphics.

Comment 6 Bournonville 2019-08-16 08:33:36 UTC
Update:

1) Performed another bios update (to version 5204) 

2) Installed / tried latest Rawhide kernel (kernel-5.3.0-0.rc4.git0.1.fc31)

* neither change made any difference to this issue.

3) Tried Fedora-Xfce-Live-x86_64-Rawhide-20190812.n.0.iso (has kernel 5.3.0-0.rc3.git1.1.fc31.x86_64) on same PC

4) Tried Fedora-Xfce-Live-x86_64-Rawhide-20190709.n.1.iso (has kernel 5.2.0-1.fc31.x86_64) on same PC

* both ran without any graphical issues !

5) Booted 5.2.7 with iommu=pt argument appended to boot line (as per https://bugs.freedesktop.org/show_bug.cgi?id=111122)

* made no difference

6) Booted new 5.2.8-200 kernel with various xfce / mesa updated rpms, i.e.

Packages Altered  (unrelated rpms removed) :
    Install  kernel-5.2.8-200.fc30.x86_64                            @updates
    Install  kernel-core-5.2.8-200.fc30.x86_64                       @updates
    Install  kernel-devel-5.2.8-200.fc30.x86_64                      @updates
    Install  kernel-modules-5.2.8-200.fc30.x86_64                    @updates
    Install  kernel-modules-extra-5.2.8-200.fc30.x86_64              @updates
    Upgrade  Thunar-1.8.8-4.fc30.x86_64                              @updates
    Upgraded Thunar-1.8.8-1.fc30.x86_64                              @@System
    Upgrade  exo-0.12.7-2.fc30.x86_64                                @updates
    Upgraded exo-0.12.6-2.fc30.x86_64                                @@System
    Upgrade  garcon-0.6.4-2.fc30.x86_64                              @updates
    Upgraded garcon-0.6.3-2.fc30.x86_64                              @@System
    Upgrade  kernel-headers-5.2.8-200.fc30.x86_64                    @updates
    Upgraded kernel-headers-5.2.7-200.fc30.x86_64                    @@System
    Upgrade  libinput-1.14.0-1.fc30.x86_64                           @updates
    Upgraded libinput-1.13.902-1.fc30.x86_64                         @@System
    Upgrade  libxfce4ui-4.13.7-2.fc30.x86_64                         @updates
    Upgraded libxfce4ui-4.13.6-3.fc30.x86_64                         @@System
    Upgrade  libxfce4util-4.13.5-1.fc30.x86_64                       @updates
    Upgraded libxfce4util-4.13.4-3.fc30.x86_64                       @@System
    Upgrade  mesa-dri-drivers-19.1.4-1.fc30.x86_64                   @updates
    Upgraded mesa-dri-drivers-19.1.3-1.fc30.x86_64                   @@System
    Upgrade  mesa-filesystem-19.1.4-1.fc30.x86_64                    @updates
    Upgraded mesa-filesystem-19.1.3-1.fc30.x86_64                    @@System
    Upgrade  mesa-khr-devel-19.1.4-1.fc30.x86_64                     @updates
    Upgraded mesa-khr-devel-19.1.3-1.fc30.x86_64                     @@System
    Upgrade  mesa-libEGL-19.1.4-1.fc30.x86_64                        @updates
    Upgraded mesa-libEGL-19.1.3-1.fc30.x86_64                        @@System
    Upgrade  mesa-libGL-19.1.4-1.fc30.x86_64                         @updates
    Upgraded mesa-libGL-19.1.3-1.fc30.x86_64                         @@System
    Upgrade  mesa-libGL-devel-19.1.4-1.fc30.x86_64                   @updates
    Upgraded mesa-libGL-devel-19.1.3-1.fc30.x86_64                   @@System
    Upgrade  mesa-libOSMesa-19.1.4-1.fc30.x86_64                     @updates
    Upgraded mesa-libOSMesa-19.1.3-1.fc30.x86_64                     @@System
    Upgrade  mesa-libOpenCL-19.1.4-1.fc30.x86_64                     @updates
    Upgraded mesa-libOpenCL-19.1.3-1.fc30.x86_64                     @@System
    Upgrade  mesa-libgbm-19.1.4-1.fc30.x86_64                        @updates
    Upgraded mesa-libgbm-19.1.3-1.fc30.x86_64                        @@System
    Upgrade  mesa-libglapi-19.1.4-1.fc30.x86_64                      @updates
    Upgraded mesa-libglapi-19.1.3-1.fc30.x86_64                      @@System
    Upgrade  mesa-libxatracker-19.1.4-1.fc30.x86_64                  @updates
    Upgraded mesa-libxatracker-19.1.3-1.fc30.x86_64                  @@System
    Upgrade  mesa-vulkan-drivers-19.1.4-1.fc30.x86_64                @updates
    Upgraded mesa-vulkan-drivers-19.1.3-1.fc30.x86_64                @@System
    Upgrade  ndctl-66-1.fc30.x86_64                                  @updates
    Upgraded ndctl-65-1.fc30.x86_64                                  @@System
    Upgrade  ndctl-libs-66-1.fc30.x86_64                             @updates
    Upgraded ndctl-libs-65-1.fc30.x86_64                             @@System
    Upgrade  parole-1.0.3-2.fc30.x86_64                              @updates
    Upgraded parole-1.0.2-1.fc30.x86_64                              @@System
    Upgrade  thunar-volman-0.9.4-1.fc30.x86_64                       @updates
    Upgraded thunar-volman-0.9.3-1.fc30.x86_64                       @@System
    Upgrade  tumbler-0.2.6-1.fc30.x86_64                             @updates
    Upgraded tumbler-0.2.5-1.fc30.x86_64                             @@System
    Upgrade  xfce4-about-4.13.7-2.fc30.x86_64                        @updates
    Upgraded xfce4-about-4.13.6-3.fc30.x86_64                        @@System
    Upgrade  xfce4-appfinder-4.13.5-1.fc30.x86_64                    @updates
    Upgraded xfce4-appfinder-4.13.4-1.fc30.x86_64                    @@System
    Upgrade  xfce4-panel-4.13.7-2.fc30.x86_64                        @updates
    Upgraded xfce4-panel-4.13.6-2.fc30.x86_64                        @@System
    Upgrade  xfce4-panel-profiles-1.0.9-1.fc30.noarch                @updates
    Upgraded xfce4-panel-profiles-1.0.8-4.fc30.noarch                @@System
    Upgrade  xfce4-power-manager-1.6.4-1.fc30.x86_64                 @updates
    Upgraded xfce4-power-manager-1.6.3-1.fc30.x86_64                 @@System
    Upgrade  xfce4-session-4.13.4-2.fc30.x86_64                      @updates
    Upgraded xfce4-session-4.13.3-1.fc30.x86_64                      @@System
    Upgrade  xfce4-settings-4.13.8-1.fc30.x86_64                     @updates
    Upgraded xfce4-settings-4.13.7-1.fc30.x86_64                     @@System
    Upgrade  xfconf-4.13.8-4.fc30.x86_64                             @updates
    Upgraded xfconf-4.13.8-1.fc30.x86_64                             @@System
    Upgrade  xfdesktop-4.13.6-1.fc30.x86_64                          @updates
    Upgraded xfdesktop-4.13.5-1.fc30.x86_64                          @@System
    Upgrade  xfwm4-4.13.4-1.fc30.x86_64                              @updates
    Upgraded xfwm4-4.13.3-1.fc30.x86_64                              @@System

* Disappointingly, made no difference - i.e, I'm still getting the same graphics glitches as originally reported with xfce unless I boot a 5.1 kernel. 

Why the livecd works on the same machine is unclear - lots of possibly related rpms are different with that.

Comment 7 Bournonville 2019-08-17 18:05:10 UTC
Further update:

I seemed to have fixed this now - essentially by setting the xfwm4 variable "vblank_mode" to the value 'xpresent' instead of 'auto'.

1) I discovered that disabling the xfce compositor on my PC removed the pixelated graphics artifacts that otherwise appear with xfce under 5.2+ kernels but not in 5.1+ kernels, i.e., the issue raised in this bug report.

However, whether running without compositor or even when using the alternative compton compositor, screen tearing then became evident in xfce sessions under both 5.2.x and 5.1.x kernels.  This is using xfwm4-4.13.4-1.fc30.x86_64. Such screen tearing did not occur in a mate or cinnamon session.

2) As a fix to both the original pixelated graphics artifacts problem and the secondary (new) issue of screen tearing, I have now set the xfwm4 variable "vblank_mode" to the value 'xpresent' instead of the default 'auto' using the xfce settings editor and reactivated the xfwm4 compositing.

So far, I have neither graphics issue with that value set when running xfce under kernel 5.2.8.

Comment 8 Talha Khan 2019-08-19 17:47:00 UTC
Glad this worked for you. I tried changing the screen tearing/vsync settings in the Plasma system settings, disabling it and setting it to "only when cheap" instead of auto but neither helped.
I tried using LXQT but the issue is even worse there, whether I use KWin or Openbox.

Comment 9 Talha Khan 2019-08-22 16:37:56 UTC
Still a problem with kernel 5.2.9 and mesa version 19.1.4-2.
FYI I'm running on a HP Envy x360 with AMD Ryzen 5 2500U APU with Vega graphics.

Comment 10 Talha Khan 2019-08-27 14:46:22 UTC
Still occurring after updating Mesa to 19.1.5-1

Comment 11 Chris Tao 2019-08-27 17:05:38 UTC
Possible same issue here. Running xfwm4 with glx vsync mode produces garbled pixels, on both modesetting & amdgpu DDX. Also tried lastest amdgpu git snapshot containing this patch: https://src.fedoraproject.org/rpms/xorg-x11-drv-amdgpu/pull-request/4
Gnome and KDE are fine with latest amdgpu DDX.

It's rzyen 3500u on kernel 5.2.x.

> Why the livecd works on the same machine is unclear - lots of possibly related rpms are different with that.

Here vsync is always off on first run. Re-login then it will use glx, which is the default. Might be a bug in xfwm4.

Comment 12 Talha Khan 2019-09-04 14:35:43 UTC
It seems to have been solved with the latest kernel, 5.2.11-200.fc30.x86_64. So far no graphics issues.


Note You need to log in before you can comment on or make changes to this bug.