Bug 174003 - Anaconda crashes when trying to format 240gb removable hard drive /dev/hdc.
Anaconda crashes when trying to format 240gb removable hard drive /dev/hdc.
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 10:42 EST by Brian Tuley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 22:38:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda text dump report (857.17 KB, text/plain)
2005-11-23 10:47 EST, Brian Tuley
no flags Details

  None (edit)
Description Brian Tuley 2005-11-23 10:42:04 EST
Description of problem:
During the final step of the installation using anaconda, the following error 
is displayed after the package selection when you hit "next" to begin 
formatting the drives: "Error informing the kernel about modifications to 
partition /dev/hdc1 - device or resource busy. This means Linux won't know 
about any changes you made to /dev/hdc1 util reboot - so you shouldn't mount 
it or use it in any way before booting." The /dev/hdc is a removable 240gb IDE 
drive that is formatted ext3 into two 120gb partitions /dev/hdc1 
and /dev/hdc2. The only solution so far has been to reinstall everything but 
do not format the removeable drive. The primary drive /dev/hda is a 40gb IDE 
drive.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369, rpm-4.4.1-21, anaconda-10.2.1.5-2

How reproducible:
everytime

Steps to Reproduce:
1. Begin the installation of Fedora Core using anaconda
2. Format dirves manually using disk druid. The first drive /dev/hda is a 40gb 
IDE drive that is formatted as follows: /dev/ha1 = /boot =102mb, dev/hda2 
= /usr = 10236mb, /dev/hda3 = /var = 5122mb, /dev/hda4 = extended 
partition, /dev/hda5 = / = 5122mb, /dev/hda6 = /home = 5122mb, /dev/hda7 
= /tmp = 1024mb, dev/hda8 = swap = 777mb, /dev/hda9 = /opt = 10652mb
3. Formatted manually the second rive a remoavble 240gb IDE as 
follows: /dev/hdc1 = /bkup/mis = 115091mb, /dev/hdc2 = bkup/001 = 123382mb
4. Custom installed network setting, firewall (allowed ssh), LinuxSE, time 
zone and various packages the hit "next" to the screen before the step of the 
installation.
5. hit "next" to begin the final installation and the system hangs for a few 
minutes then displays the error mention in the description.   
  
Actual results:
Received the error message mentioned in the "Description" andI saved the dump 
to a floppy disk and rebooted and ran the install again with the same error 
even when I tried to create one partition on the second drive. Finally had to 
run through the setup again but the last time I did not format or partition 
the second hard drive.

Expected results:
Fedora Core 4 should have formatted the second removable drive into two 
partions as it had when it was formatted with Fedora Core 3 and finished with 
the installation and rebooted.

Additional info:
I will submit the crash report once the bugreport has been filed. Also the 
machine is a Dell optiplex 260 Pentium 4 2,80ghz 521 memory. The hard drives 
are both Western Digital. The Removable case is a Store Caes Technology.
Comment 1 Brian Tuley 2005-11-23 10:47:17 EST
Created attachment 121399 [details]
anaconda text dump report
Comment 2 Jeremy Katz 2005-11-24 22:38:34 EST

*** This bug has been marked as a duplicate of 160693 ***

Note You need to log in before you can comment on or make changes to this bug.