Bug 174052 - proper resolution for monitor is not listed
Summary: proper resolution for monitor is not listed
Status: CLOSED DUPLICATE of bug 115679
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-24 02:26 UTC by Jason
Modified: 2014-06-18 09:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 20:43:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason 2005-11-24 02:26:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
During the install of FC5T1 my video card and monitor are detected properly.  When firstboot comes up and I am prompted to select the resolution and color depth the proper resoltion is not listed.  I have a Revolution IV video card and a SGI 1600sw LCD monitor.  The resolutions for this monitor are 800x512 and 1600x1024.  I can attach a working xorg.conf file if it would help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  install fc5t1
2.  the correct resoultion is not there
3.
  

Actual Results:  The screen does not appear correctly because the wrong resolution is used.

Expected Results:  I should be able to select the proper resolution, which should automatically write the correct settings to xorg.conf so X will work correctly.

Additional info:

Comment 1 Paul Nasrat 2005-11-29 14:49:17 UTC
If you edit /etc/X11/xorg.conf to have the correct resolutions does it work?  If
not please attach /var/log/Xorg.0.log as an uncompressed attachment.  The
modelines are in rhpxl extramodes.

Comment 2 Jason 2005-11-29 14:58:03 UTC
If I add the modelines by hand, or copy my old working xorg.conf to the system
Xwindows works fine.  The modelines might be in rhpxl but firstboot did not show
800x512 or 1600x1024 as a resolution I could select.

Here are the working modelines:
ModeLine "1600x1024d32" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 7
+Hsync +Vsync 

ModeLine "1600x1024d16" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 5
+Hsync +Vsync 

ModeLine "1600x1024d08" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 1
+Hsync +Vsync 

ModeLine "800x512d32" 54.375 800 800 840 848 512 512 514 515 HSkew 7 DoubleScan
+Hsync +Vsync 

ModeLine "800x512d16" 54.375 800 800 840 848 512 512 514 515 HSkew 5 DoubleScan
+Hsync +Vsync 

ModeLine "800x512d08" 54.375 800 800 840 848 512 512 514 515 HSkew 1 DoubleScan
+Hsync +Vsync 

Comment 3 Wade Mealing 2006-01-11 04:18:35 UTC
This looks similar to 174686

Comment 4 Jason 2006-01-11 15:37:18 UTC
This bug is for s-c-d not listing 800x512 and 1600x1024 as valid resolutions for
my monitor when firstboot calls s-c-d (just after the intial install is complete).
174686 happens after the install is complete.  S-c-d crashes when I try to
launch it.

Comment 5 Jason 2006-01-16 22:24:15 UTC
system-config-display still not list 800x512 and 1600x1024 as proper resoultions
for my monitor.

Comment 6 Jason 2006-02-15 13:01:29 UTC
system-config-display-1.0.36-1 still does not list 800x512 and 1600x1024 as
proper resoultions for my monitor (a SGI 1600SW).

Thanks,
Jason

Comment 7 Chris Lumens 2006-02-21 20:43:08 UTC

*** This bug has been marked as a duplicate of 115679 ***


Note You need to log in before you can comment on or make changes to this bug.