Bug 115679 - installer uses wrong resolution for sgi 1600sw monitor
installer uses wrong resolution for sgi 1600sw monitor
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i128 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Reopened
: 174052 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-02-14 14:33 EST by Jason
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-03 14:46:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
working XF86Config (2.79 KB, text/plain)
2004-02-14 14:35 EST, Jason
no flags Details
working xorg.conf (2.94 KB, text/plain)
2004-09-24 10:48 EDT, Jason
no flags Details
driver (2.83 KB, application/octet-stream)
2004-10-05 11:30 EDT, Jason
no flags Details
X.log from todays rawhide install attempt (33.90 KB, text/plain)
2006-07-09 19:17 EDT, Jason
no flags Details
XConfig.test from todays rawhide install (3.27 KB, text/plain)
2006-07-09 19:18 EDT, Jason
no flags Details
x log from startx without a xorg.conf (37.16 KB, text/plain)
2006-08-03 21:52 EDT, Jason
no flags Details
august 13 x.log (33.66 KB, text/plain)
2006-08-13 15:15 EDT, Jason
no flags Details
august 13 xconfig.test (711 bytes, text/plain)
2006-08-13 15:17 EDT, Jason
no flags Details
x log for fedora generated xorg.conf (aug 26) (34.89 KB, text/plain)
2006-08-26 18:19 EDT, Jason
no flags Details
fedora generated xorg.conf (aug 26) (523 bytes, text/plain)
2006-08-26 18:20 EDT, Jason
no flags Details
x log for my xorg.conf (aug 26) (34.88 KB, text/plain)
2006-08-26 18:21 EDT, Jason
no flags Details
my xorg.conf that used to work (aug 26) (2.05 KB, text/plain)
2006-08-26 18:22 EDT, Jason
no flags Details

  None (edit)
Description Jason 2004-02-14 14:33:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)

Description of problem:
Fedora Core 2 test 1 now recognizes my SGI 1600SW flat panel.  The
problem is anaconda is using the wrong resolution for the install and
the XF86Config that is generated is also wrong.  The install trys to
set the monitor to 1024x768.  This is not one of the two resolutions
the monitor works at.  800x512 and 1600x1024 are the two resolutions
that the monitor works best at.  I think the installer needs to run at
800x512 for the install.  I will attach a copy of my XF86Config that

Version-Release number of selected component (if applicable):
what comes with the FC2 test1 iso

How reproducible:

Steps to Reproduce:
1.  try to install FC2 test 1 
2.  on a system that has 
3.  SGI 1600sw monitor

Actual Results:  the installer is using the wrong resolution so what
is displayed on the screen is a little 6x8 (approx.)  version of the

Expected Results:  The whole flat panel should be used

Additional info:
Comment 1 Jason 2004-02-14 14:35:34 EST
Created attachment 97673 [details]
working XF86Config
Comment 2 Jeremy Katz 2004-02-16 23:28:34 EST
Can you give the output of `/usr/sbin/kudzu -p -c MONITOR` as well?

Also, does booting with linux resolution=800x512 work?
Comment 3 Jason 2004-02-17 22:23:39 EST
There is no output.  I ran the command from inside Xwindows and
nothing happened.
Comment 4 Jason 2004-02-17 22:37:57 EST
I rebooted with the following in the grub.conf

kernel /vmlinuz-2.6.1-1.65 ro root=LABEL=/ acpi=force resolution=800x512

The bootup still did show up at 800x512.  The following showed up
during boot.

Using tsc for high-res timesource
Console: colour VGA+ 80x25

I tried the kudzu command after the boot and still no output.
Comment 5 Brent Fox 2004-03-12 16:20:02 EST
Jason: don't add the "resolution=800x512" line to your grub.conf. 
Boot off the Fedora CD #1 and type 'linux resolution=800x512' at the
isolinux boot screen.  Does that work?
Comment 6 Jason 2004-03-24 19:07:55 EST
I tried booting from the FC2 test 1 CD and put in linux
resolution=800x512 and pressed enter.  The system started a text based
Comment 7 Jason 2004-04-01 16:12:56 EST
I tried the FC2T2 disks.  When I boot off the CD, let it load, the
installer starts a X windows install using the wrong resoultion.  When
I boot off of the CD and type in linux resolution=800x512 X windows
bombs out and a text install starts.
Comment 8 Jason 2004-04-13 12:41:17 EDT
Will this request make it in FC2?
Comment 9 Jason 2004-05-27 17:45:47 EDT
Will you please get this fixed for FC3?  The request to add support
for this monitor has been around since bug 58003 (Jan 2002).
Comment 10 Jason 2004-07-24 17:01:40 EDT
I have tried FC3T1 and the resolution is still wrong.  
Comment 11 Jason 2004-08-30 16:46:32 EDT
Will this be fixed for FC3T2?


Comment 12 Jason 2004-09-24 10:46:35 EDT
I just tried FC3T2 and the resolution is still wrong.  Please fix
this.  I am attaching a working xorg.conf.
Comment 13 Jason 2004-09-24 10:48:30 EDT
Created attachment 104270 [details]
working xorg.conf

working xorg.conf
Comment 14 Paul Nasrat 2004-10-04 07:27:54 EDT
What is the output of:

kudzu -p -b ddc

Comment 15 Jason 2004-10-04 23:18:43 EDT
class: VIDEO
bus: DDC
detached: 0
driver: unknown
desc: "Number Nine Visual Technology Corporation REVOLUTION(tm) IV"
mem: 32768

The above is the requested output.  I am sorry it took so long.
Comment 16 Paul Nasrat 2004-10-05 08:05:36 EDT
Your monitor does not support ddc probing - do you have a windows INF
file off a driver disk for that monitor - if so please attach and we
can get added to the monitor DB - you'll have to manually select the
monitor but once we have the details it should just be doing that in

If not let me know and I'll hunt one down.
Comment 17 Jason 2004-10-05 11:30:14 EDT
Created attachment 104783 [details]

Comment 18 Jason 2004-10-05 11:35:47 EDT
Will this allow anaconda to use the correct resolution during install?
 Right now anaconda tries to use 1024x768 and the monitor works, but
not well.  When using 1024x768, the monitor displays two screens, one
is about one inch from the upper left hand corner.  Its size is about
4 inches by 5 inches.  The second screen starts two inchs below the
first and only about the top third is visable.  It would be great if
anaconda could use the proper settings during the install.

Thank you for your help.
Comment 19 Paul Nasrat 2004-10-11 11:44:34 EDT
Comment #18 - no if we can't probe the monitor we can't work out
resolutions.  You can pass resolution=XxY to specifiy an alternate

Reassigning to hwdata for INF processing.
Comment 20 Bill Nottingham 2004-10-11 11:49:21 EDT
The monitor is already in MonitorsDB; has been since January of 2004.
Comment 21 Jason 2004-10-12 23:17:26 EDT
I just booted from the FC3T3 CD with linux resolution=800x512 and I
ended up with a text install.  X failed to start, then X tried the
vesa driver and failed, and then the text install began.

Here is the x.log

X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.21-14.ELsmp i686 [ELF] 
Current Operating System: Linux localhost.localdomain 2.6.8-1.541 #1
Wed Sep 1 18:00:30 EDT 2004 i686
Build Date: 28 September 2004
Build Host: tweety.build.redhat.com
	Before reporting problems, check http://wiki.X.Org
	to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.8-1.541
(bhcompile@tweety.build.redhat.com) (gcc version 3.4.1 20040831 (Red
Hat 3.4.1-10)) #1 Wed Sep 1 18:00:30 EDT 2004 
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/tmp/ramfs/X.log", Time: Tue Oct 12 22:05:47 2004
(++) Using config file: "/tmp/XConfig.test"
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) Failed to load module "record" (module does not exist, 0)
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) VESA(0): No matching modes
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support at http://wiki.X.Org
 for help. 
Please also check the log file at "/tmp/ramfs/X.log" for additional

Comment 22 Bill Nottingham 2004-10-12 23:26:41 EDT
Bouncing back to anaconda... there's nothing else that can be done in
the hwdata monitor database.
Comment 23 Jason 2004-11-12 14:00:36 EST
I have just installed FC3 on my system.  I passed linux nofb
resolution=800x512 to the installer.  X refused to start and I ended
up with a text install.  After the install rhgb tries to start but
keeps crashing.  I have to boot into single user mode and copy my
corrected version of xorg.conf to /etc/X11.  Anaconda does not select
the resolution.  Please update anaconda so it uses the correct
settings when I pass resolution=800x512 to the installer.

Comment 24 Paul Nasrat 2005-02-24 03:50:35 EST
Our default modelines (and x.orgs) doesn't have modes for 800x512 does booting
with resolution=1600x1024 work?  
Comment 25 Jason 2005-02-28 11:34:04 EST
Good question.  I have not tried that resolution.  I will try it tonight.
Comment 26 Jason 2005-02-28 22:56:26 EST
If I boot with linux resolution=1600x1024 then when X tries to start my monitor
loses signal and the light on the monitor flashes yellow.  If I boot with linux
nofb resolution=1600x1024 then when X startx I get a screen, but the window is
not even close to fitting into the monitor.  X is still using the wrong
resolution or modelines.
Comment 27 Jason 2005-03-21 22:33:55 EST
I just tried FC4T1.  If I boot linux nofb, I get a X session this is about 4
inches by 6 inches.  If I boot linux nogb resolution=800x512 I get can't get
address for localhost:6001: Name or service not known
(mini_wm:599):GTK_WARNING **: cannot open display: :1

If I boot linux nofb resolution=1600x1024 then I a large X screen, but the
screen is shifted a couple inches to the right.

In short still broke, please fix.
Comment 28 Jason 2005-07-12 17:23:23 EDT
I installed FC4 on my system.  If I boot linux nofb, the system falls back to a
text install.  If I boot linux nofb resolution=800x512, the installer dies.  It
stops responding, I have to hit the reset button.  If I boot linux nofb
resolution=1600x1024 I get a screen of black and white bars.
Comment 29 Christopher 2005-10-26 11:40:24 EDT
I'm having hte same issues. I'm using a Compaq Proliant 850r, which has a 
Cirrus Logic chipset for video. It seems to be probing the video, but it can't 
probe the monitor. The monitor is an OptiQuest Q71 17" monitor. What baffles 
me is that the following commands don't do ANYTHING different:

linux ide=nodma resolution=800x600
linux ide=nodma resolution=640x480
linux ide=nodma nofb resolution=800x600

(I was using ide=nodma becuase this setup keeps telling me my CD's are bad).

What happens is that on all three of these commands, when anaconda loads, it's 
the same resolution everytime...which pushes the bottom and right sides out of 
my monitor.

I'm using FC4 which was downloaded just a couple of nights ago.
Comment 30 Christopher 2005-10-26 12:22:48 EDT
OK, I swapped out my OptiQuest for an NEC MultiSync LCDM1700+ 17" Flat Panel. 
Same deal.

I noticed that when Anaconda probed my video card it says: Cirrus Logic 
GD543x. And it still can't probe my monitor. It says Unknown Monitor. Can I 
assume at this point that maybe it's the video card that's not allowing the 
monitor to be probed?

I'm going to try some of the resolution=XXXxYYY commands again. However, I'm 
am doubting any success there. Whatever resolution Anaconda is picking can't 
fit on a 17" monitor. 

OK, so now that I have my flat panel on, I can get a little more info here. So 
I tried linux resolution=640x480. When I get to Anaconda, I see the Welcome to 
Fedora Core screen in its same old off the right/bottom of the screen 
position. When I ask the monitor to tell me it's setting, I see that it is 

OK, now I'm going to try higher resolutions this time and see what happens.

linux resolution=1024x768 ide=nodma

Well. That's interesting. My monitor is telling me that it is at 640x480@60Hz. 
So, what I'm guessing here is that if the system can't probe the monitor, it's 
dropping down to a default of 640x480....even though the screens don't work 
seem to work at that resolution.

Which brings up my next question. If there is a resolution keyword, what use 
is it if the system uses its own default?
Comment 31 Christopher 2005-10-26 12:27:50 EDT
Sorry to post again, but I thought I'd follow with a little additonal info. I 
was thinking that maybe the video card couldn't handle the resolution. I had 
Win2K on this server earlier, and I'm pretty sure I had it in 800x600 mode. I 
looked at one of my other servers (I don't have any other PL850's around). 
I've got a pair of Proliant 2500R's runinning around here with Win2K on them. 
The video card driver says Cirrus Logic 5430/5440. The Win2K drivers appear to 
allow them to operate up to 1280x1024 (Although it looks like crap since its 
only 16 color) and that's on a Dell 15" monitor. It could defintely handle 256 
colors at 1024x768 (and look OK) on the same 15" monitor. Sooo, I'm thinking 
that the video card should be able to handle 800x600 at a minimum, but the 
resolution keyword isn't doing anything for some reason.
Comment 32 Paul Nasrat 2005-10-26 12:43:48 EDT
Christopher - please note this bug is against specific hardware - for issues
with other hardware please file a seperate bug.
Comment 33 Jason 2005-11-23 21:10:27 EST
FC5T1 installer recognizes the hardware I have but still does not use it
correctly.  Xwindows still uses the wrong resolution.  Also during firstboot
when I am asked to choose the correct the resolution, the proper resolutions are
not available (I know I will file another bugzilla about this) I mention it in
case the two are related.
Comment 34 Paul Nasrat 2005-11-28 18:38:28 EST
Jason what was the bug number for the resolution issue.
Comment 35 Jason 2005-11-28 20:23:34 EST
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174052 is to have firstboot
show me the correct resolution so I can select it so firstboot will create a
working xorg.conf so Xwindows will work properly.  
Comment 36 Jason 2006-01-04 10:19:45 EST
I downloaded yesterdays boot.iso and tried to do a ftp install of rawhide. 
Anaconda still does not use the proper resolution for my monitor.
Comment 37 Jason 2006-01-16 17:21:22 EST
anaconda in FC5T2 still will not use the proper resolution during the install.
Comment 38 Jason 2006-02-15 15:53:56 EST
todays boot.iso still does not use the proper resolution for my monitor.  
Comment 39 Chris Lumens 2006-02-21 15:43:20 EST
*** Bug 174052 has been marked as a duplicate of this bug. ***
Comment 40 Chris Lumens 2006-02-21 15:46:39 EST
I have some patches to pyxf86config, rhpxl, and the extramodes file that should
get support for this into shape.  Will be rebuilding and testing those over the
next couple days.
Comment 41 Chris Lumens 2006-02-22 16:15:12 EST
Waiting on bug 181292 and bug 182430 before you can test this.
Comment 42 Chris Lumens 2006-03-06 16:54:13 EST
All the pieces should be in place now.  Please test with FC5 and let me know if
this is working better for you.
Comment 43 Jason 2006-03-06 17:39:17 EST
I tried todays rawhide boot.iso and it crashed so I opened

Since the other bugs were closed today I will try this again tomorrow.
Comment 44 Jason 2006-03-07 08:54:12 EST
Some good news and bad news.  The good news is that I nolonger get the trackback
that I was getting yesterday.  The bad news is that when X started from todays
boot.iso, I got a white screen.  What do you need from me to id the problem?

Comment 45 Jason 2006-03-09 09:32:41 EST
I found the problem.  The file generated by pyxf86config is wrong.  pyxf86config
says the HorizSync is 31.5 - 48.5, it should be HorizSync 31.5 - 110.
Comment 46 Jason 2006-03-09 09:47:09 EST
Comment 45 fixes 1600x1024 resolution.  There is a HUGE problem with 800x512. 
When I startx at 800x512, the resulting X is 4 times larger than the monitor,
hence the huge reference :)  I don't know how to fix that problem.
Comment 47 Jason 2006-03-10 09:22:35 EST
Will this be fixed for FC5?  Please, pretty please, pretty please with a cherry
on top...
Comment 48 Jason 2006-03-22 08:44:51 EST
Chris can you please reopen 182430 to have this problem fixed?
Comment 49 Jason 2006-07-09 18:59:55 EDT
Hello again.  I tried the rawhide boot.iso today to if see the boot resolution
problem which has been open since 2004 (2002 if you count earlier bugs) has been
fixed.  It has not.  Will you please fix it for FC6?  Here are the logs from
todays attempt.
Comment 50 Jason 2006-07-09 19:17:27 EDT
Created attachment 132151 [details]
X.log from todays rawhide install attempt
Comment 51 Jason 2006-07-09 19:18:04 EDT
Created attachment 132152 [details]
XConfig.test from todays rawhide install
Comment 52 Chris Lumens 2006-07-19 10:25:10 EDT
rhpxl should now just be writing out a skeleton X config file, since X can
figure out most of the configuration stuff on its own anymore.  Please try FC6
test 2 and see if that makes any difference for you.  Otherwise, it is most
likely going to be an X bug.
Comment 53 Jason 2006-07-19 11:56:57 EDT
Since FC6 test2 is not going to be available for at a least a week, did you want
me to try todays daily boot.iso image?  
Comment 54 Jason 2006-07-19 12:59:05 EDT
I tried today's rawhide boot.iso and things are back to where they were in 2000.
 The screen is nolonger white, but the installer uses the wrong resolution so
the monitor is not usable.
Comment 55 Mike A. Harris 2006-07-25 08:39:11 EDT
The xorg-x11-server-Red-Hat-extramodes.patch contained in the
xorg-x11-server package, still contains the special mode required for
the SGI 1600sw monitor.

If you are experiencing a problem with current rawhide, please file a brand
new bug report with the details in it, against the component that you think
is the most relevant for the problem.  If you think it is a configuration
issue, then "system-config-display" is probably the right choice.  If you're
unsure, then do a text mode install, and try to get X to work afterward.
If you can get it to work, then it is probably just a configuration issue.

Keep in mind that this type of hardware is very non-standard and rare
nowadays, and may not work at all well with newer X releases, or newer
operating system releases.  It can be a manpower resource strain to have
to engineer and maintain custom workarounds for rare legacy hardware on
an ongoing basis, in particular if it breaks every release as things
change.  We do try to provide workarounds for issues of this nature when
possible, however they're fairly low priority overall, and it can be
hard to justify spending the manpower resources on an issue that affects
only a small number of people if there are hundreds of more critical
issues affecting thousands of people.  Just a thought.
Comment 56 Jason 2006-07-28 12:31:09 EDT
I don't know how anaconda works.  I have no idea where the problem is located. 
My job as a bug reporter is to report problems and answer questions you have so
the problem can be fixed.  If you ask a question I will get the answer.  The
problem is even though the xorg-x11-server-Red-Hat-extramodes.patch contains the
right settings is not working.  Since you or someone you know has knowledge of
how anaconda works and how the video setting gets chosen you should be able to
figure out where the problem is occurring.  I don't have that knowledge.

Can you tell me where I can view the xorg-x11-server-Red-Hat-extramodes.patch so
I can see if the mode line is correct.  As I stated in Comment 45 the solution
to this problem is easy.
Comment 57 Adam Jackson 2006-08-02 15:54:35 EDT
The problem is DDC on your monitor is busted, so it's not probing the sync
ranges correctly.  The INF file for the monitor doesn't actually have sync range
info, just some static sync pairs.  I stuck a hack in the i128 driver to attempt
to force the sync ranges to something suitable for the 1600SW when we detect one
but don't have working DDC; please test xorg-x11-drv-i128-1.2.0-3 or later.
Comment 58 Jason 2006-08-03 21:50:55 EDT
I download the file you requested and its dependencies.  Things are getting
better.  I can now comment out the modlines in my xorg.conf and its works fine.
 However if I understand X it is supposed to be able to run without a xorg.conf
so I decided to try it.  It works after a fashion.  The screen comes up but is
mostly garbage.  I traced the problem to X not using the correct resolution. 
What should have is X should probe for the a video card and monitor and if the
video card is a Number Nine Revolution IV video card and a SGI 1600SW monitor
then the resolution should be 800x512 or 1600x1024 and not to bother with any

I will download fridays rawhide boot.iso and see if it works there.
Thanks for your help,
Comment 59 Jason 2006-08-03 21:52:52 EDT
Created attachment 133606 [details]
x log from startx without a xorg.conf
Comment 60 Jason 2006-08-04 13:06:36 EDT
todays boot.iso gives a backtrace after I enter download location for a ftp
install.  I will try it again when this problem is fixed.  see bug 201367 for
details of the backtrace if interested.
Comment 61 Jason 2006-08-08 13:16:43 EDT
bug 201367 is fixed but now I have

I will keep this bug updated.
Comment 62 Jason 2006-08-13 15:14:16 EDT
The august 13 boot.iso works again.  The bad news is anaconda is still using the
wrong resolution.  Attached is the Xconfig.test and X.log from the trial.
Comment 63 Jason 2006-08-13 15:15:50 EDT
Created attachment 134106 [details]
august 13 x.log
Comment 64 Jason 2006-08-13 15:17:47 EDT
Created attachment 134107 [details]
august 13 xconfig.test
Comment 65 Chris Lumens 2006-08-18 12:55:58 EDT
What happens if you pass resolution=<valid res> to anaconda?
Comment 66 Jason 2006-08-18 14:51:37 EDT
linux resolution=800x512 yeilds a screen that overfills the monitor.  The
background menus appear to have a resolution of 800x600 so that the bottom of
all the screen are cut off (you can't click on or see the next button).

linux resolution=1600x1024 yeilds a screen that is 1600x1024 (as the mouse
travels) but the background menus are in the upper left hand corner approx 4x3
inchs in size.  Pop up message boxes appear in the middle of the screen like
they are suppose to.

Comment 67 Chris Lumens 2006-08-24 15:53:29 EDT
anaconda's UI is only designed for 800x600 and 640x480 (if it has to).  It
sounds to me like running anaconda at 1600x1024 for you is showing you the
entire UI, but it just doesn't fill the entire screen.  That's about what
happens on more interesting platforms a swell.  As long as X after reboot works
correctly for you with the config file as written, I'd think this bug could be
closed out.
Comment 68 Jason 2006-08-25 09:05:33 EDT
So far during the last month of testing I have not been able to install rawhide.
 It is not because of rawhide breakage, just problems with anaconda, the kerenl,
etc.  I will try installing rawhide later today or tomorrow and see if things
have gotten any better since last week.
Comment 69 Jason 2006-08-26 18:17:53 EDT
I was able to install rawhide today (august 26) and quite frankly rawhide is
garbage, nothing works.  I have updated the appropriate bugs with info.  

On this issue X is now really screwed up.  It is so screwed up that my original
xorg.conf no longer works.  I tried startx with the fedora generated xorg.conf
and my xorg.conf and neither work.  I am attaching logs.
Comment 70 Jason 2006-08-26 18:19:47 EDT
Created attachment 134989 [details]
x log for fedora generated xorg.conf (aug 26)
Comment 71 Jason 2006-08-26 18:20:21 EDT
Created attachment 134990 [details]
fedora generated xorg.conf (aug 26)
Comment 72 Jason 2006-08-26 18:21:50 EDT
Created attachment 134991 [details]
x log for my xorg.conf (aug 26)
Comment 73 Jason 2006-08-26 18:22:26 EDT
Created attachment 134992 [details]
my xorg.conf that used to work (aug 26)
Comment 74 Adam Jackson 2006-08-28 14:26:15 EDT
That's bizarre, you should at least be getting a message saying why the
1600x1024 mode was rejected.

I'm building a new version of the i128 driver that might fix this.  Please try
1.2.0-4, which should be in tomorrow's rawhide, or if you're impatient I've
uploaded it to:

Comment 75 Jason 2006-08-28 16:44:07 EDT
Yes I am the impatient type.  I installed the two packages (driver and
debuginfo) and the fedora generated xorg.conf.  Good news I now get a working X
setup.  The bad news is looks like the screen is shifted a couple of pixels to
the right and 1 pixel down.  This makes moving up and down a webpage using the
scrollbar difficult.  Now to get my 5 button intelimouse to work.

Finally progress after all these years.  Thank you.
Comment 76 Jason 2006-08-30 14:47:59 EDT
When I shutdown X I get a screen of garbage.  If I do a setfont then it clears up.
Comment 77 Jason 2006-09-01 12:08:33 EDT
A couple of problems:

1) X nolonger reads the xorg.conf.  The default resolution is 1600x1024 but I
prefer 800x512.  I added the proper settings to xorg.conf and they are ignored.
 This also affects my mouse.  I have a 5 button intellimouse and the back and
forward buttons no longer work.  Again I think this is because X does not read
the xorg.conf file

2) When I logout of X the screen is scambled with garbage characters.  I don't
think the i128 driver is reseting the vga mode correctly (my knowledge of this
area is quite limited so take with a grain of salt).  Since there is no fb for
this card I use the vga console at 80x25

Comment 78 Jason 2006-09-01 12:15:40 EDT
3) the screen at 1600x1024 is 1 pixel down and 2 pixels to the right to far.  no
way to test 800x512 since there is no way to switch to it.
Comment 79 Jason 2006-09-08 17:09:26 EDT
An old copy of my xorg.conf in /root was being used and caused my x not reading
xorg.conf problem.  The only two problems left are:
1) the new driver causes the screen to be 1 pixel down and 2 pixels right
causing the right side of the desktop to be cut off.

2) when I exit X the monitor gets all screwed up with garbage characters,  I
don't think the i128 driver is reseting the vga mode correctly (my knowledge of
this area is quite limited so take with a grain of salt).  Since there is no fb
for this card I use the vga console at 80x25.  a setfont fixes the problem.

Comment 80 Adam Jackson 2007-05-03 14:46:45 EDT
1600SW setup fixed.

Note You need to log in before you can comment on or make changes to this bug.