Bug 1740668 - crash from accept() in beast frontend
Summary: crash from accept() in beast frontend
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.3
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: z1
: 3.3
Assignee: Casey Bodley
QA Contact: RUDRA PRATAP
Erin Donnelly
URL:
Whiteboard:
Depends On:
Blocks: 1726135 1762910
TreeView+ depends on / blocked
 
Reported: 2019-08-13 12:50 UTC by Casey Bodley
Modified: 2019-10-22 13:29 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-12.2.12-64.el7cp Ubuntu: ceph_12.2.12-57redhat1
Doc Type: Bug Fix
Doc Text:
.Ceph Object Gateway no longer terminates when there are many open file descriptors Previously, the Ceph Object Gateway with Beast front end terminated with an uncaught exception if there were many open file descriptors. With this update, the Ceph Object Gateway no longer terminates.
Clone Of:
: 1762910 (view as bug list)
Environment:
Last Closed: 2019-10-22 13:29:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 41169 0 None None None 2019-08-13 12:50:23 UTC
Red Hat Product Errata RHBA-2019:3173 0 None None None 2019-10-22 13:29:42 UTC

Description Casey Bodley 2019-08-13 12:50:23 UTC
Description of problem:

Some errors from accept() are incorrectly thrown as exceptions, which are not caught and terminate the process. One such error is EMFILE (Too many open files) and is easy to reproduce with ulimit.


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. Run radosgw with a small number of file descriptors, ie 'ulimit -n 128'
2. Execute several client requests on different connections

Actual results:

radosgw terminates with an uncaught exception

Expected results:

radosgw logs an error and continues trying to accept connections

Additional info:

Comment 17 errata-xmlrpc 2019-10-22 13:29:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3173


Note You need to log in before you can comment on or make changes to this bug.