This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 174098 - installer hangs when loading sata_sil module
installer hangs when loading sata_sil module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: FCMETA_SATA
  Show dependency treegraph
 
Reported: 2005-11-24 10:31 EST by David Bentley
Modified: 2013-07-02 22:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 18:08:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg uotput as requested (33.76 KB, text/plain)
2006-02-21 16:23 EST, David Bentley
no flags Details

  None (edit)
Description David Bentley 2005-11-24 10:31:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.10) Gecko/20050811 Fedora/1.7.10-1.1.1.legacy

Description of problem:
Fails at the installing sata_sil screen with garbled text and locks up

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1696_FC5

How reproducible:
Always

Steps to Reproduce:
Do a normal graphical boot


Actual Results:  locks up as in description

Expected Results:  install to continue

Additional info:

My machine is based on an Intel SE7505VB2 server board with twin 2.8G XEON's

The fix for the problem is as it was for a previos RAWHIDE install.

The garbled text then said disabling IRQ10 and on viewing the text console 
(CTL+ALT+F3 or F4 a message can be seen suggesting that you try booting passing
the kernel option IRQPOLL).

I can confirm that this does work and that it is only necessary for a NON-SMP
kernel as after instalation it can be removed from grub.conf (added during setup
as a kernel parameter but found not to be required as with test1 only SMP kernel
now used previously RAWHIDE included both kernels)
Comment 1 Rahul Sundaram 2006-02-20 06:10:25 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 David Bentley 2006-02-20 17:48:33 EST
Chanded to fc5test3

I can confirm that with the boot kernel in fc5test3 that the problem has
changed somewhat.

You now get a pause of about 60 seconds while the sata_sil and garbage text are
shown but now it does eventually continue but with the following consequence.

The SATA drives in the system are not available.

If I boot with LINUX IRQPOLL the 60 second pause is no-longer evident and the
SATA drives in the system become available.

I haven't as yet done a complete instalation as I haven't got all the CD's
downloaded yet but this has no bearing on this bug.

NB the hardware I am seeing this on is an INTEL SE7505VB2 board with dual 2.8G
xeon processors 2 x SATA HD (not in raid mode) 2 x PATA HD and a DVD reader
and DVD writer.
Comment 3 Dave Jones 2006-02-20 23:30:26 EST
can you attach the output of dmesg -s 128000  please ?
Comment 4 David Bentley 2006-02-21 11:39:30 EST
After which version of the install (ie with or without me adding LINUX IRQPOLL)
Comment 5 David Bentley 2006-02-21 16:23:10 EST
Created attachment 124984 [details]
dmesg uotput as requested

This was grabed as soon as possible after a new install giving linux irqpoll as

the boot option. But having got through the install with the initial NON-SMP
kernel the reboot when instalation is complete was into the installed SMP
kernel.
Comment 6 David Bentley 2006-03-22 11:35:30 EST
Installed FC5 on my INTEL SE7505VB2 based system yesterday (21/03/06) without
any visible problems.

No need to add irqpoll and no gabage text visible when the sats_sil driver was
loading and no pause either.

I had noticed that for most of the recent non-smp kernels that I tested prior to
the release of FC5 that you no-longer need IRQPOLL and hoped that this would be
the case with FC5.

So for the INTEL SE7505VB2 board this problem has now been fixed.

Leaving this open for now as it is shown as blocking # 172490 (FCMETA_SATA)
Comment 7 steve 2006-06-01 11:30:47 EDT
I'm a newbie to linux - but also have this problem. Tried to instal FC5 from DVD
received yesterday (so I guess it is the latest distribtion)

My controller is Sil3112a in a PCI card with latest bios, non-raid. Get garbled
message at load sata-sil driver, then drive is not available, and can't install.
Tried acpi=off, etc,. 

Have win2k running okay and boots from same controller/disk.
Comment 8 Dave Jones 2006-10-16 17:44:33 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 9 David Bentley 2006-10-23 07:32:15 EDT
See my comment #6 FC5 installed OK.

I am going to upgrade the system showing the problem to FC6 (FRESH INSTLL) so 
if all is still OK I will close it then.
Comment 10 David Bentley 2006-10-23 07:40:47 EDT
Soory forgot to tick the box
Comment 11 David Bentley 2006-11-03 18:08:32 EST
closing see #9 above.

Note You need to log in before you can comment on or make changes to this bug.